Very high CPU usage

Pc: ryzen 7 4800, Nvidia RTX 2060, proprietary drivers
on ubuntu 20.10 via Jack
both versions lv2 and VST3, hosted in Ardour 6.5
load Abbysun preset, play some chords
DSP load goes up to 90%

4 Likes

Same here with

  • Kubuntu 20.04
  • enabled KX Studio Repository
  • Jack or ALSA (same result)
  • CPU : i7-8565U (4 Sockets x 2 Threads)
  • GFX: Intel Corporation UHD Graphics 620 (Whiskey Lake)
  • OpenGL 3.1 active

When loading Vital in standalone and doing nothing 2 processes are using each up to 100% CPU in powersafe mode.
When switching to POWER mode the 2 processes are using 40% each CPU.

Last test with 1.0.3 … nothing changed since the first 1.0.0.
Same with loading it in Bitwig 3.2.8

1 Like

BTW @enorrmann could you fix the type in the titel “hugh” to “high” so people can better find that thread?

2 Likes

if u dont have an internal/external gpu vital is gonna take more cpu power to render its UI

I don’t understand because how can i see something on my screen, when there is no internal or external GPU ?
I’m working on my notebook with an Intel GPU like i descriped in my post and I think the thread starter has as well a GPU on his system …

if you have an intel/ryzen gpu it means that the computing units for your graphics are in your CPU

If you have any gpu like an nvidia one or a radeon one then your cpu will be fine as long as its not ancient af

Ah ok. Hmm that’s a big show stopper, because then I can’t really use vital :frowning:
I hope there will be a patch, that enables me to use my baught version as well on a computer with a normal hardware setup.

3 Likes

updated the title and some hardware specs

2 Likes

I also have this problem with the Linux version. Patches just go through the roof with usage and distort. Ceramic is a good example

1 Like

I think some people on linux are having issues connecting to the right FFT library and it’s using a much slower version instead. Looking into why.

3 Likes

in my case, using vital on renoise , vital eat 25% of the cpu, on vcv rack 1,5%
hidding the vital interface it stop to eat the cpu

1 Like

On my Kubuntu with KX Studio it uses

  • libfftw3-double3/focal,now 3.3.8-2ubuntu1
  • libfftw3-single3/focal,now 3.3.8-2ubuntu1

That should be the latest version, isn’t it?

Jesus, this is eating my CPU alive!17 24

WOW! Thats just playing a single note…

It peaks at 70%

Rests at 10% Constant.

Ableton Current:
Single instance of Vital
No other plugins in use

It certainly uses up CPU power, but I personally find it about as intensive as an instance of Serum.

When I first loaded it up I did notice “crackling” or “skipping” when playing the “Ceramic” keys preset at about 25% CPU load in Ableton, but I think that had more to do with my Sample Rate as I run Ableton through Voicemeter Banana for livestreaming purposes. When going direct through my Steinberg CL1 using the ASIO drivers the problem disappears.

Going into the “Advanced” tab and changing the over-sampling to 1x (it defaults to 2x) the percentage definitely dropped a bit. Again, usage is pretty similar to Serum IMO.

Specs:
Ableton 10.1.25
Windows 10
Ryzen 7 3700X
AMD Radeon 5700XT
32GB Memory at 3600 MHz

I have found that oversampling is 8x by default…
when I add the plugin as vst3 or lv2 in linux, or when I reopen a project using vital, oversampling is set to 8x
this is perhaps the cause of most of the issues with high cpu and glitchy sounds

For me and few other people I’ve spoken to on the Discord the main reason why CPU usage is so high while the editor is opened is because it is running at uncapped frame rates when using NVIDIA. With a decently fast GPU this will mean that Vital will keep rendering frames until you max out a CPU core. This also makes resizing using the handle in the bottom right corner next to impossible. The Windows version running through Wine doesn’t seem to have this problem. The Windows version is also using an OpenGL 4.6 context while the native Linux version uses an OpenGL 3.2 profile, which might be part of the issue. Forcing vsync through mangohud also doesn’t work in this case (although artificially limiting the frame rate does).

For the record, this particular issue only happens with NVIDIA. I checked with Intel/Mesa and that’s using an OpenGL 4.6 context like you’d expect and vsync works properly there.

Hi,

  • I’m on Windows 10,
  • Reaper v6.16.,
  • Intel i5-7300HQ,
  • NVIDIA GeForce GTX 960M.

I’m on the Scarlet Solo audio interface, it probably doesn’t matter but just in case.

Vital has an abnormal CPU usage while the UI is opened/being rendered in DAW (~40%). Both VST2 and VST3. Even on an initialized patch, 2X oversampling. If the interface is closed but Vital is playing back, everything seems rather normal.

The standalone version also consumes similar amount of CPU, but closing the interface doesn’t make a difference.

1 Like

Something is wrong because on my old internet computer which is an ancient i5 3470 with Intel graphics I find the CPU usage very reasonable.

On my Studio computer which is an i7 8700K with Nvidia 1050 I barely notice the CPU.

Both running Windows 10. Is everyone reporting high CPU on laptops ?

I am. Vital is the only plugin with this behaviour, in my instance only when the GUI is opened. Playing back a complex patch with the UI closed seems normal on the other hand.

For comparison opening most plugins’ GUI, CPU jumps by 1%, Vital by ~39 - 44%. It fluctuates between those values.

Maybe it has something to do with the GPUs on Laptops. Or your Power settings. Do you have the High Performance profile selected ?