Tip for Linux Users with high CPU usage

A follow up this thread which is now locked Very high CPU usage

I managed to sort my issue by changing the setting of the CPU Frequency Scaling Governor.

This is a good video explaining this setting https://youtu.be/Pc-uw1ena2k

Mine was set to OnDemand and when I switched to Performance, the cpu MHz increases dramatically and I have no problems running Vital anymore.

Also, if you use Cadence, there is a drop down menu to change this setting, enabled if you have the “indicator-cpufreq” package installed.

Edit: I just noticed indicator-cpufreq installed a menu in the system tray as well, which you can change the scaling profile with. So it may be useful regardless of using Cadence.


This makes a huge difference. I’ll have to experiment with other options later to see what will give me the best results.

It is generally advisable to have the governor set to performance, since switching modes can (or used to) cause all sorts of problems with audio apps on linux.