Text to Wavetable Doesnt Work

Unfortunately, it made another issue…
This is what happened when I allowed the Vital application through the firewall: it did a weird flashy thing and I couldn’t operate anything. I’d show a video, but it won’t let me because I’m a new user.
Edit: standalone doesn’t have the epileptic episode but it still won’t let me use TTWT

@misterbeefpv because the speech audio is pulled from Google which is why it’s such good quality. Trying to code your own from scratch is no easy task!

1 Like

I finally got TTWT to work by swapping from a free user to a subscription user maybe it doesnt work on the free version.

Hey, joining to the rest here!
I use Vital free on WIN10, allowed vital through my firewall & all of the data and presets are running smoothly.
still got the same error, with both the standalone and VST (using LMMS), despite being fully connected to the internet.

Using my account with Vital Plus, TTWT works fine (up to 5 per day)
Using a test account I just made with Vital Basic (free), I get the error rendering speech
Exactly the same configuration, I just logged out and back in with the other.

Seems most people getting the error (excluding where it fixes itself in time) are using Basic

I think you need to buy the FULL version in order to get it working, i have the free version and it does not work for me too.

Ah, I had a bug in some server code that expected an account row and if you just downloaded the free version and never interacted with anything else that info wasn’t there, so would give an error.

I just fixed the server code and tested it with a fresh account so it should now work for everyone (no update needed since it was just on the server side)


Great stuff and thanks very much for resolving this issue! I had exactly the same issues but it now works great. I’ve only tried it in the standalone version at the moment.

Thank you!

Wow, thank you!

same over here

Thanks for this fix , works now Mac/mojave here

Thanks Working now!

What worked for me is to click on the 3 horizontal lines in Vital (menu system) log out of your account there. Then log back in. After that - no connection messages. You don’t have to close out or disconnect - just log out and back in…

sorry but no one was answered !! How is it possible? do we only talk to each other?

no one gives a solution but only says it works for me and not for me?

I tried to create another account but it doesn’t work anyway … so it’s not a bug in the account code … or the bug is created all the time

The main issue was solved. It would just show an error when you tried to do text-to-wavetable for some accounts. Now it works correctly.

If it still doesn’t work correctly it might be some firewall settings on your computer. Maybe try it from the standalone version to see if that works.

it was one of the first attempts I made some time ago … who knows if it’s because I have version 1.0.3 that maybe it’s unstable

Please do yourself a favor and upgrade before posting any request.

If it has been fixed in the past (which it has) than that means, you need the current version (which is 1.0.5).

So please upgrade. Most likely it is gone. No issue posted since Nov 2020.