Producer Presets / Free Preset Sharing Site

Hey everyone!

I wanted to introduce myself and share a site I recently launched called Producer Presets. The site is basically a place for artists/producers to find, download, discuss and share presets for their audio software.

Shortly after we launched, one of the most requested plugins we kept hearing about was Vital, and after playing around with it a bit (pretty amazing) we added it up to the site:

https://www.producerpresets.com/plugin/vital

We’ve got a small collection of presets so far, but it’s growing by the day.

Anyway, Producer Presets is totally free - you don’t even need to register to find/download presets. We scan all presets for malware when they are uploaded and are hoping to become a resource to community.

We also have support for Universal Audio, Waves, Arturia, iZotope, Soundtoys, Xfer, u-he, FabFilter & Valhalla - but would love to know if there are any other products you’d like to see.

Thanks for making an amazing product - and please let me know if there’s anything I can do to make the service more useful!

Michael Witwicki

6 Likes

Hey Michael, thanks for sharing. Unfortunately, I get an error message as it says the preset which I dl (Snail) was created on a newer version. Are you familiar with this problem? I run 1.03.

Tnx

Hi @levasaf - this issue has been documented - Cannot load Patch created in 1.0.4 in 1.0.3 - Use Standard Major.Minor.Patch Versioning Semantics.

The latest version of vital is 1.0.4 - you can find this here -> https://account.vital.audio/?product=vital

I’m running 1.0.4 on mac in Logic without problems, but there have been some issues with this release, particularly for linux users I believe (https://forum.vital.audio/search?q=1.0.4%20%23bugs)

1 Like

Thank you so much for responding @andrew_a! Do you think we should be requiring a version number when users upload a preset for Vital? This is one of the things I’ve been struggling with and wasn’t sure how to test.

as 1.0.5 is out now i think this problem is solved for the future.

and i wanted to say that i can´t use your site with my old computer. but most sites work fine with it.

Hi @michael.witwicki - is this post, @Tytel comments that, as of 1.0.5 (there’s a windows build for 1.0.5 online now actually), he’s moved to a system where (typically) patch updates wouldn’t cause issues, and perhaps the same for minor version changes. So in the short / medium term this might not be a big issue for you.

Thanks so much!

Hey there! Any chance you could let me know which OS / Browser combination you are using (and which versions)? We are definitely using some newer build tools which may be causing the issue.