MPE Enabled not Maintained when Duplicating Vital in Ableton

Hello- I’m on macOS 10.15.7 Catalina (can’t upgrade), using Ableton Live 11.3.13 with Vital 1.5.5 as a VST3.

When I duplicate an instance of Vital, it will still show ‘MPE Enabled’ but it won’t be. I have to toggle it off and on to restore MPE- specifically poly pitchbend.

Having this work consistently is important to me, as I use MPE to explore alternate tuning systems. I’m often wondering why things aren’t sounding right before I remember I need to retoggle MPE.

I am unsure if this issue persists with other DAWs or plugin wrappers.

Thanks for your consideration in fixing this Matt!

I believe that’s just ableton, I think with serum you need to re-enable mpe on each instance, no?

No- if I duplicate a serum instance, MPE remains enabled in both Serum & Ableton and works as expected. FWIW I also have ‘MPE Enabled by Default’ checked (as well as ‘Limit Polyphony to One of Any Note Number’ deselected) for Serum’s default settings. (and at one point, I’d clicked the save icon in global preferences after setting those settings.)

When I duplicate a Vital instance that has both ‘Enable MPE Mode’ checked in Ableton, and ‘MPE Enabled’ set on under ‘Tuning’ within Vital’s settings, the duplicated track will still say that both are checked- but MPE does not perform correctly until I toggle ‘MPE Enabled’ off and on in Vital.

Just thinking out loud here so this could work or not but try this. Open up a fresh instance of Vital not touching its default settings and make sure ‘MPE Enabled’ is working (so yeah, go through the toggle/re-toggle thing if necessary). Then right-click on the device and “Save as Default Preset”. Does that change anything when duplicating?

Unfortunately not- same behavior as before when duplicating, where ‘MPE Enabled’ will be checked in Ableton & ‘MPE Enabled’ in Vital, but MPE retuning won’t work until I toggle it off then on in Vital.

Also interesting is that creating a brand new instance of Vital after doing this does not actually keep ‘MPE Enabled’ on even after using ‘Save as Default Configuration’ in Ableton.

I think something about this particular parameter is not stored properly with the plugin state.

Ah, they must have fixed the bug I was thinking about.
Unlucky, looks like you’ll just have to remember to re enable mpe for now

Is this the same thing as my post? If so I have windows and this could be a universal problem.

Probably the same issue. I’m on Mac OS Sonoma 14.3/Ableton 11.3.21 and getting this. Worth noting the exact same thing is happening to me with Arturia Pigments. I contacted Arturia support about it and they couldn’t reproduce it. Seems like a bug with Ableton + certain plugins, as some other MPE synths I have are working fine in Ableton.

Good to know, it may be ableton related then for sure if it’s across platforms and synths