The "MPE enabled" button doesn't stay active upon reloading song in Reaper

Hi Matt.

First off… amazing synth! :slight_smile: loving it so far.

Did a quick search for this bug but not quite the same as I’ve seen others report.

Basically. If I create a new initialised patch in Vital 1.08 (using Reaper v6.33+dev0806 - August 6 2021) and click “MPE enabled”. I will edit Vital a bit record in some MPE pitch bending goodness and then save the song.

If I then load up the song again, the pitch bends are not happening until I disable and then re-enable the MPE enabled button.

So it appears that the MPE is not saved currently. I’ve not tried saving an actually patch but if possible, I’d rather not do that if possible.

As a side note. In Vital 1.07 and below. The MPE enabled button was always off upon loading the song again but in 1.08, the MPE enabled button seems to save state with the song but doesn’t actually enable the MPE features till turned off and on again. :slight_smile:

Let me know if you need any other tests etc. Thanks!

1 Like

I’ve looked around Reaper to try and find a solution, but couldn’t find anything. I don’t have any MPE devices, so could you send over a sample project having the problems described?

It’s not specific to reaper, and was reported many times before. MPE settings are recalled graphically but not “tonally” so to speak

The MPE button appears to be on, but it is not engaged internally. Turning it “off” (aka, nothing changes because it’s already off) then back “on” fixes it.

This makes Vital pretty much unusable with MPE as this has to be done every single time a project is opened, on every single instance of Vital.

Exactly, as I said this has been reported many times, let’s hope it will be fixed soon!

Yeah. Hope this gets fixed as for now, only solution is to always render everything down or manually switch them back which isn’t great :slight_smile:

I’m having this problem too, in Ableton Live 11. Hopefully this gets fixed quickly!

I know it’s free, but this bug that has been discussed like a dozen times over the course of over a year makes Vital unusable. Would imagine you’d want to fix something that makes your synth unusable, no?

It’s not free. It is a commercial synth with a free version. Like I said in your other post on the same subject Matt is working on a major update.

But since you’re using the free version you probably shouldn’t be having such a pissy attitude about something that 99% of the user base doesn’t care one bit about.

I could not possibly care less about MPE support since I don’t have a capable device.

So just be patient.

1 Like

Was MPE mentioned as part of the big update?

This is a forum used to discuss the Vital synth and I’m using it as such. Your disinterest in MPE adds precisely 0 value to the discussion.

Pissy comments like this:

Add zero value to the forum

Vital is perfectly usable for me because I don’t use MPE toys.

But If you want to make a feature request then make it in a respectful manner. Don’t insult the developer and that goes for any developer. You’ll find you get much more positive results without the negativity.

Not pissy, this isn’t a feature request, there’s a literal BUG that breaks an EXISTING feature, and it has been brought up continuously from day 1.

You not using MPE toys isn’t smugly impressive to anyone, you are not the arbiter of what is important or usable in a complex instrument. That MPE exists in Vital implies it’s meant to work properly.

There was no disrespect. This is a BUG not a FR, it affects many many users (to the point of unusability), and has received no engagement from the dev. Sometimes speaking up gets necessary attention, this is how things work.

Also dude sincerely you’re coming off as sort of a dick here lol, funny given your moral insufferability.

And clearing the slate, happy to hear there’s a big update. Hoping MPE is considered as part of that. Synth is amazing.

I can’t believe I didn’t try this before but as a temp fix for this. You can use automation to force the mpe enabled button to on at the start of a song :slight_smile:

That should work as a temp fix :slight_smile:

Will give this a go, is it reliable so far?

I’ve not had time to try it much as on other work at the moment but as long as you have a daw that chases automation it should be fine yes and it worked in reaper on the one test project I “fixed” by doing this. It only has to trigger it once and it won’t break until loading song again. :slight_smile:

1.51 seems to have fixed this bug for me so far. Thanks Matt! :slight_smile:

1 Like

Are you sure this is working? The reason I ask is because I think it works but then find out it doesn’t after re-opening a project. If it was fixed in Reaper it wasn’t in Ableton.

Is it related to: