Vital is crashing Reaper

Hi all,

I’m having an issue in which anytime I try to run Vital 1.5.5 inside Reaper, the program crashes. This happens for the vst3 and the clap versions. I’m running Fedora Jam 39 on a fairly old Dell computer (I think it’s from 2011). However, other synth plugins are working just fine.

I’ve tried installing the older version of Vital. I’ve even tried installing the Windows version and running it through Yabridge. But nothing is working.

I’ve tried running Reaper from the terminal to try to get a clearer picture of what’s going on, but the only notification I get in the terminal is the message “Killed.” No other details.

Any idea what might be going on?

Thanks for any help you can provide.

Does this thread help?

A quote:

Currently I’ve installed a game which uses DirectX-11, and which runs like a charme.
But Vital, version 1.5.5, currently is still not working in default process handling, it still needs ‘Each instance in an own process’.

Dunno if things work similarly on Tux.

Hey thanks. I was wondering if it was a graphics card thing.

But I don’t think so. I just was able to open Vital in Ardour. So clearly it’s working on my machine’s hardware.

Maybe it’s an issue with Reaper?

In that thread I linked they talk about a Reaper thing.

Ardour might handle plugin processes differently by default.

last i heard Matt doesn’t test with linux so much if at all. i’m using arch, vital is crashy, but it is least crashy if the compatability settings in reaper are ‘separate process’ or ‘dedicated process’ i forget which right now. try both. but it still crashes, mostly when showing the gui during project playback. maybe there’s some things to learn at the vital discord, which i haven’t checked.

I have been using Vital 1.55 VST3 on Windows 10, with Reaper v7.09, on a HP Omen-X laptop (Intel i7-770HQ). I was also using Vital 1.55 VST3 on the last Reaper 6 version (6.83 I think).

I’m not a power user, but I don’t recall ever getting crashes with it.

I don’t have any good suggestions unfortunately.

1 Like

op didn’t really emphasize it but they’re on linux.

I have no idea what changed, but Vital is now working.

I’ve been installing lots of other software, and just for the heck of it I uninstalled every Vital installation I had tried.

Then, I reinstalled the .rpm and now it’s working like a charm.