How to propper remove Vital?

i5-13500, RTX 4070, 32 GB DDR4


My previous PC was Ryzen 5 2600, GTX 1060, 64 GB DDR3 and Win-10.
With this I had six, seven FX-Windows with Vital open (even with three OSC’s each), and no problem.

Since I use Vital with my new PC Vital causes to crash the DAW and so to say after the fifth or sixth OSC and two, or three FX-Windows open.
One FX-Window, no problem. Two FX-Windows, less then five OSC’s (AFAK) no problem.

Meanwhile I had installed upto the newest version of Vital (1.5.5), and my idea is to downgrade to maybe 1.0.5 (I really do not know which version I used with my previous PC.).
But what is the propper way to uninstall Vital?
(I’ve done it, but e.g. all folders in ‘Documents’ are still present after deinstall.)

I need to get Vital working with my rig! :slight_smile:

Best regards

This folder contains your presets and wave tables, so it’s nice of the uninstaller to leave them untouched. Just install the older version 1.0.5 or whatever and you’ll be good to go. Thing to keep in mind is that all the presets you’ve made with a newer 1.0.5 + version can not be loaded in the older version.


Already noticed…, but this is not that important yet.
I need a full functionally Vital! :slight_smile:
BTW: I had no luck with 1.0.5, 1.0.6. Still the same behaviour: Two, three FX-Windows and/or five/six OSC’s and the DAW is crashing.
But, and I’m pretty sure that I used 1.0.6 with my previous PC, and this worked like a charme.
And this happens only with Vital, I can have a project with e.g. HELMSynth with seven FX-Windows open, working like a charme.
Do I have no Vital FX-Window open (or only one), also, all is working like a charme.


Are you using the vst2 or the vst3 ? Do they both act the same ? And have you tried opening Vital in buggy mode ?

Hmmm, I do not have VST2. I do have VST and VST3…
Both acts the same, I tried.
Just gave that “Buggy Mode” a try (VST and VST3), but still the same…, five, six OSC’s in two open FX-Windows causes the DAW to crash.
If even I would know, what the reason is, that already would help. Especially because Vital worked with my previous PC like a charme.

Did your previous PC also have Windows 11 and the same GPU ?
EDIT saw it was windows 10. Most problems come from the graphics AFAIK.


I had a look of some error reports (Vital, Reaper), but couldn’t find any so far.
So I watched inside Windows ‘Event Viewer’ and there is always as reason ‘Error with OpenGL32’.
I already had a search in the internet, what causes could be with OpenGL32 errors, but couldnt find really helpfull.
But I’ve found a thread in the Reeper-Forum
< Is there a Reaper crash log? - Cockos Incorporated Forums>
And that (each instance of Vital in an own process) works for me.
But of course this is only a workaround, isn’t it?
Best regards

1 Like

I would not call it a workaround, because it’s the solution to a problem until there is an updated version of Vital, thing that I find strange is that the latest version of vital should use DirectX and not OpenGL32.

Or are you still working with 1.0.5 /1.0.6 ?


Currently, yes, I’m using 1.0.5.
I had again a look into the ‘Event Viewer’ of Win-11, and (I do not know exactly when I used 1.5.5) there is an error log with Reaper and ‘dxgi.dll’.
I also called ‘dxdiag’ and my DirectX is version 12 (RTX 4070).
Maybe I could install Vital 1.5.5 and run a DirectX library update (that also DirectX-11 apps have no problems)?

I don’t know anything about DirectX or even OpenGL and how to update those, on my PC they just work :smiley:
But I’m on Windows10 so maybe if you feel adventurous , you can try to update DirectX :scream:


Just for interest:

Currently I’ve installed a game which uses DirectX-11, and which runs like a charme.
But Vital, version 1.5.5, currently is still not working in default process handling, it still needs ‘Each instance in an own process’.
I hope that can be fixed soon. :slight_smile:
Best regards

1 Like