Vital does not load in Ardour/Mixbus on Linux

First of all i want to thank you for this great Synth. Especially for the Linux world vital is a gamechanger. Thank you very much for that!

I don’t know if you have already been made aware of the error described in the Ardour Forum ( I get the same error message when I try to start vital 1.0 in Ardour 6.3 on Ubuntu 20.4. Robin Gareus, one of the developers of Ardour writes: “Please ask plugin author to statically link the plugin, so that it is self-contained and does not depend on system-wide libs”. Is that possible?


I get the same error message loading version 1.0.3 as lv2 in Ardour 6.5 on Ubuntu 20.10

/lib/x86_64-linux-gnu/ undefined symbol: g_input_stream_read_all_finish

The standalone version works ootb.

1 Like

Working here on Mixbus 6.2.26 linux.

The same for me:

In Ardour 6.5, on Linux Mint 20.1 loading the LV2 the Ardour log says:

2020-11-26T21:04:07 [ERROR]: LV2: Failed to instantiate plugin

Same for VST3:

2020-11-26T21:05:49 [INFO]: VST3</usr/lib/vst3/Vital.vst3>: Cannot load VST3 module: ‘/usr/lib/vst3/Vital.vst3/Contents/x86_64-linux/’

In Carla (2.2.0) instead, both LV2 and VST3 load and work fine.

1 Like

same for me, Ardour 6.3, Ubuntu 20.04

1 Like

Same for me… Ardour 5.12, Ubuntu 20.04

LV2 still failing to instantiate plugin Ubuntu 20.04 Ardour 6.5 Latest version of Vital . As soon as this works I will purchase :slight_smile:

Static builds for both VST and LV2 would be great. I am having crashes with Bitwig as well :frowning:

Hello there ,would you mind sharing your linux distribution and version please ?

Operating System: Linux Mint 19.1
Kernel: Linux 4.15.0-135-lowlatency

Thanks Ewen , another ubuntu based distro .

Just like to mention it, because it seems some have overlooked it.

Linux Support is:
Ubuntu 18.04 or newer - only.

I know it does not help if you do not have Ubuntu 18.04, but

Same issues with Ardour 6.6 and Manjaro

Same here! Any clues?

I just bought the Plus version but can’t load the plugin in my DAW.

I’m also getting this error in Ardour 6.6.0 on Ubuntu 20.10

Reading player:Vital took 2 microseconds, final size = 0
lilv_lib_open(): error: Failed to open library /usr/lib/lv2/Vital.lv2/ (/lib/x86_64-linux-gnu/ undefined symbol: g_input_stream_read_all_finish)

I also can’t load the lv2 in Ardour, and the stand alone version doesn’t show up in qjackctl.