Vital crashing on linux with user made and preset sounds



  • I decided to test vital before buying it, so I have the free account, and downloaded the Linux.deb version. Website login > Account > says it’s version 1.07.
  • Using Reaper 6.77 on PopOS! 22.04 (a Debian / Ubuntu based distro)
  • I logged into vital from Reaper to download all the free presets in ~/.local/share/vital/the_free_presets
  • When I check ~/.vital/Vital.config, it says synth_version = 1.5.5, and work_offline = true… Though I have tried the following steps while being signed in… And I’m not sure why it says it’s 1.5.5, when the download on the site says 1.07…


  1. I create a track and load Vital, it works fine whether it’s CLAP, VSTi, or VST3i.
  2. I’ll make my own sound, save it, and close Reaper.
  3. When I reload the Reaper project, it crashes, and won’t ever let me open the file again. It doesn’t matter whether it’s CLAP, VSTi, or VST3i. It always crashes, won’t even let me load it.
  4. I’ve tried the same with only the free presets. And whether using CLAP, VSTi, or VST3i, it usually crashes (easy mallet, destruction, and salomon always crash). Other synths I’ve tried aren’t doing this (like Surge XT).


Anyone know how to fix this / what’s going on? Any help is appreciated, because I really would like to buy the full version, though the number of people reporting these types of problems makes me cautious.

Sounds odd. Most recent version is 1.5.5. From the download page, click all downloads and grab the .deb for 1.5.5.

Uninstall what you have and remove or move the vital.config. Then install the new .deb. see if that fixes the crash. You might need to do a rescan of vst and clap before you load vital though.

Clap wasn’t supported until 1.5.x, so not sure it’s going to fix it for you.

Thanks for the help, but what you said only fixed part of the problem. Here’s what I did:

  1. I uninstalled everything from the old .deb installer
  2. Made sure /usr/lib/vst3, and all other files associated with vital were completely removed, including the config file. I even did a sudo rm -rf folder/ for anything leftover and related to vital.
  3. I downloaded the 1.5.5.deb version instead of the older one, reinstalled.
  4. Rescanned all instruments in reaper, logged in through reaper, downloaded all the free presets.
  5. Vital presets will now reopen after saving the reaper file (which is better than before)… But any sound I make and save on vital just crashes the next time I open the reaper file.

Any other ideas on what the problem might be?


I would edit my previous post, but all I did to fix it after Derrek’s advice was turn off my computer, turned it on next morning, and now it works fine.


1 Like