Vital causes my FL studio to visually stutter

so I was using the free version of vital and whenever I played a note the window of vital would start to freeze and unfreeze in a consistent pattern, at first I thought it was my applications running in the background but that didn’t solve anything, then I tried my other projects and realised that it was specifically something to do with the synth as everything else didn’t make it stutter. i don’t know what is wrong and need some help trying to fix this issue, there is no problem with the audio it’s just visually but it has made FL crash once.

What are your system specs ? CPU, Video Adapter, OS ? Vital runs just fine in FL Studio on two different systems here, even this old i5 with onboard Intel graphics. First thing I would suggest is to use the VST 2 version and not the VST3 version at least for now.

RYZEN 7 3700XT 8 core 3.6GHz
radeon RX 5700XT
Windows 10
32 GB DDR4 3600 RAM

lemme know if you need anything else

Well there’s certainly no reason that system should be having problems with Vital. Do you have any Scaling settings other than 100% either in FL Studio or Windows? Does it occur with both the VST 2 and VST 3 version? Do you have another DAW to test Vital in to see if the issue occurs there as well? That would rule in or out FL Studio as the cause. Does it occur in a fresh project with only Vital loaded? What version of FL Studio are you using?

It’s basically your GPU is choking, it even happens with my GTX1070.
The solution is to close most of the plugins you are using in FL Studio and just open 1 vital every time you want change something, just press F12 then open the Vital you want to edit. It gets heavier when you even just open 2 instance on the screen.

Vital is just too much GPU intensive, you’ll see a lot of people complaining about it at the other thread… and Matt seriously need to fix it. (or maybe implement an option to lower the refresh rate since it’s constant trying to render at 60fps)

Interesting because I don’t have any issues related to Vital’s UI myself.
Also using FL Studio and I never press F12 (I let all plugins hide behind playlist by just pressing it, it’s faster & doesn’t break your layout like F12 in case you have some additional metering plugins).

it doesn’t really break the layout it just close all of the window, if you open the plugin that where closed they stay where they are and even the whole layout you made. Some VST hates being mixed by some other VST UI, in my case Vital which using OpenGL and Waves plugins DirectX tend to chock FL Studio visual render. It’s like stuttering all around, even tho a GTX1070 should have enough power to push even on a 1440p 144hz…

and that makes me have to open them again, so basically breaks what I see on the screen - this is what I meant. ^.^
Anyway everyone is free to use whatever methods they want, I don’t like to have to open mixer, playlist & few plugins every time I open FL (pressing F12 after opening project would close all windows which literally would cause it) - and these are what I always keep visible while working on music. ^.^

Doesn’t happen with my GTX 1050ti or even the onboard graphics of this system. Something else is at play. You’ll never figure out what unless you’re willing to troubleshoot the problem and that involves eliminating what isn’t the cause until you’re left with what is causing the problem. Some people including myself have no issue whatsoever running Vital in FL Studio. Some people do have problems. There is a reason for that.

I already solved mine, because some VST doesn’t like being mixed while opened with other VST UI while rendering it, although my PC is exclusive for music use, so I dont have anything at the OS rather than the latest driver from Nvidia and AMD chipset of my BIOS, so if you dont have that then lucky you your Windows OS is working at your will. because mine aint doing it for me. Maybe it’s FL Studio but my version is the latest.

But in my end it’s definitely something is wrong with Vital with various GPU and drivers and seems to be not in FL Studio because some of you arent having these issues

although lately I notice that, if I tried to let Vital opened and then cover it with playlist then open another vital again it starts to stutter as you can see in this video, I captured it on 60fps. If I close the other 2 vital that was at the back of the playlist the framerate goes back to normal smooth without a problem, it maybe it’s FL Studio problem but I still dont know maybe if Matt @Tytel can take a look since I do not know any further trouble shooting of this because I dont know such tools for the end user to test it out…

PS : I bet this is the stutter problem that OP is having in FL Studio, it get worst when you have 4 instance opened at the back of the playlist. Although if it is all rendering at the foreground it’s fine no lag or stutter.

yes it is, the only difference is FL itself freezes and unfreezes

Well I don’t know what to tell you guys. Works fine here. There must be a reason why it doesn’t for you.

1 Like

mine does freeze as long as 10 secs when it reach 4 or above at the background of the playlist, you can even see it in my video where I opened 2 instance and then covered it with the playlist, FL Studio starts to crumble like it takes a quite a while to redraw another Vital upon being closed.

I have no idea which is which, but as far as I can only say is my OS right now is clean install since 4 days ago and yes I dont even use anti virus… so still a weird stutter, maybe it’s because im using AMD CPU?

I wanna know what full spec is your PC is so I can compare to mine.