Vital 1.5 public release

I updated that build a couple times so that must have caused a small difference in file size.

Weird about the virus warning though. I did just move download source locations so that might have caused it?

Tripping virus warnings with new binary builds is relatively common though I haven’t seen that happen within firefox. So it’s safe to use Vital, I haven’t seen any evidence of anyone hacking my servers and changing builds.


Ok then… It is a false alarm.
Thank you Matt, also for a great product.

UPDATE: Only Firefox version 105.0.1 (in Linux Mint 21 and Ubuntu 22.04.1 - snap version here) shows the virus warning for the Linux (deb) build. A slightly older version of Firefox (105.0) does not have this issue. There must be something with the latest Firefox that causes the problem. Definitely a false alarm…

In Chrome: “VitalInstaller.deb is dangerous, so Chrome has blocked it.”
For Vital 1.5.4 I have this message for zip, deb and rpm. For Vital 1.5.3 for deb and rpm, but not for zip.

Hmmmm yeah I’m seeing this too now.
I just diffed the binaries from my build machine and the ‘unsafe’ one downloaded from the site and they’re exactly the same so I don’t think there’s any man in the middle attack going on or that the servers were hacked or anything.

Interestingly old builds are also getting marked as malware. I did move where my binary files are hosted from so that’s probably what the issue is here, not sure what’s causing it though.


@Tytel As of this morning, my Mac refuses to recognize .vitalbank as a valid extention. Any zip files I try to convert into .vitalbanks remain as zip files that can’t be imported into Vital.

I’m using Vital 1.5.3 on macOS Mojave and I’ve confirmed this issue with others on PC as well.

This feature was working just fine yesterday. Is this a known issue?

Edit: Downgraded to 1.0.7 and I’m now able to convert .zip files into .vitalbank files again, so it appears to be an issue with the new build(s).

Installed 1.5.4 on a Mac. Standalone app does not run at all. Both VST3 and CLAP plugins crash immediately in Bitwig 4.3.8. What gives? Is there a secret way to make it run on my combination of hardware and software? Could it be that a custom skin I was using on Vital 1.0.7 causes problem now?
Please help.

I tried to download it, but Norton stopped it “Malicious Download Cancelled”

Yep custom skin might cause the crash apparently

If you’re running an older mac (before 2012) that could cause an issue - which I’m looking into.

It might be the custom theme. If you go into ~/Library/Application Support/vital could you send me the files you find in there to make sure they’re not causing the issue?

Not sure if I understand. You’re creating your own zip and then renaming the file in mac and it won’t let you change the extension?


Yes, you’re right my MacBook Pro is from 2019 :frowning: (Damn, time flies, it feels like I bought it yesterday)
To test the skin idea, I reinstalled Vital 1.0.7, switched to default skin, installed V1.5.4 again, and it did not help at all, still the same issues. I think my Mac is too old now, perhaps. Would be great if you could figure out how to deal with the older models. Thank you very much.

I am not sure how to send you files that you requested. Email?

Oh, wait, you said older than 2012, so my Mac is not that old (2019), for some reason I thought you said 2022.

Sure, you can email them to

1 Like

That’s exactly it. :slight_smile:

In 1.5.3, when I change the extension from zip to vitalbank nothing happens and the folder remains a zip.

After downgrading to 1.0.7, I’m able to change the extension again and my computer reads the file as a vitalbank - complete with the icon change and all.

Hi, just installed Vital 1.5.3 on my High Sierra Mac mini and the gui is flashing…

hi. when i install it for windows i got 1.0.8 for VST3, but 1.5.3 for VST2
maybe some wrong .vst packed or just missing version change?

Jups, welcome to the club of old mac users with the new Vital. :laughing: You probably have a Mac from before 2012. The 1.5.3 version of Vital is written for Macs with a newer graphic card. Matt is aware of this problem and (hopefully) making a version for older Macs….

1 Like

I see 1.5.4 has been pulled? Anyway, it didn’t work on my M1 mac. 1.5.3 does though.

confirmed. didn’t fire up on linux for me either.