I found the previous Vital Installer?

I said quite plainly that I had observed the same fault on Chrome, Firefox, and Safari on MacOS as well.

So I’ve only just downloaded, so could be a timely thing - was just checking out a potential issue with LV2 rendering and seeing if its present in older versions too which is when I noticed it


It’s not what I say you should see it’s what I see every time I log in on Windows 10.

I’m sorry for coming across with my temper. I’ve beaten my head on this wall for a long time, and the responses left me feeling as if I was being trolled. That tends to make me hot under the collar.

1 Like

That might be an explanation though. If you get consistent good results from a Windows browser but bad results for Mac or Linux, that would point to something needing addressing on the far end. BTW: the only Windows box I had was for a startup, and that was to run a dongle programmer for USB serial chips. I otherwise avoid Windows as much as possible. I’ve been pretty much a UNIX-oid only guy for the past 22 years.

Seems it has also affected others around here New version crash on linux Manjaro and also seems to be an issue with more stringent TLS requirements on some OS’es causing a cert issue on the updater - wonder if its related :man_shrugging:

As you can see on my latest post that’s not quite true, neither in Windows 10, nor in MacOS X 10.13.6 nor in the Linux boxes of @jimqwerty4 and @caowasteland (and probably also in the Ubuntu VM that i will install tomorrow).

Maybe if some other user is following this thread and it works for him / her, he or she can give us some clue as to why it doesn’t work for us. :man_shrugging:

Ok I just logged in to my Vital account for the first time from my Kubuntu system using Firefox and the All Downloads page loads just fine as shown in my screenshots above so there is likely something else to blame other than systems running Linux.

If there is a “bug” on the website why doesn’t it affect everybody ?

There has to be something causing the page to show for some people and not others.

No its true for me on two systems running Win 10 and one running Kubuntu Linux so there is something else at play.

What version of Vital are you guys using ? Free,Plus, or Pro? What part of the world are you from ? I saw reports from people in China having problems just logging in so maybe it’s region specific.

For the record I’ve been using computers since the mid 1980’s and have done a lot of beta testing for developers in the VST and DAW world so I’m just trying to help figure out what’s going on.

As I said, I also logged into Windows 10 (Firefox and Edge latest versions) and it reproduces the same behavior as on MacOS and Linux … that is: empty lists :man_shrugging:

I think that’s not the problem. As I see it, no one here is blaming anyone. We just have a problem and we are trying to find out what is the cause of that problem, that’s all.

p.d.: why are people so upset these days? Is it because of the Coronavirus?

I’m not upset at all and I’m not blaming anyone. I’m just trying to help you guys figure why you’re not able to see the version list like I am.

Obviously there is something to “blame”. But we won’t find anything out if we don’t share information.

I’ll start…I purchased the “In The Mix” Vital Plus pre-order version and am in the Southwest United States.

Again what version are you guys using and from what part of the world? We may find a clue in your answers.

It doesn’t appear to be Operating System related so it’s a process of elimination until we find out why this issue affects some people and not others.

I am using the free version. I was not that interested in the additional things given the general leanings of most of the sound design I’ve heard. That’s not to say Vital isn’t a very powerful engine that should be able to make sounds I do like. Maybe there’s a distinction in how the website’s presented to non-purchaser / non-subscribers.

BTW: has anyone here watched Joe Armstrong’s “The Mess We’re in?” In terms of hairiness and misbehavior in large systems, this is a nice summary of the life to which we seem to have been conscripted.

Ok so maybe that’s the difference. Maybe the Free version has different access to older versions in the “All Downloads”. If everybody who is experiencing this issue is using the Free version then that might be the answer.

1 Like

NOT maybe, THAT’S the difference!!!

I just bought the Vital PLUS (22€) to check if what you say is true, AND ITS TRUE!. I got all the versions to download after clicking “All downloads”! . Free Vital versions DON’T SHOW older versions to download!

So, the problem is SOLVED! :partying_face:

Thanks @teksonik, @caowasteland, and jimqwerty4. :hugs: :pray:

BTW, Greeeeaaaat Synth for sound design!

Thanks a lot for the link, @caowasteland! … I didn’t know him! :+1:

Thanks for putting cash toward the debug; maybe this is something that should be stated specifically.

Joe was one of the creators of Erlang; he was a great programmer with a wicked sense of humor. I wish he were still on the planet.

Hmm thought I fixed this. Basically if you haven’t done anything to create an account row in my database it didn’t work.

OK fixed it (again) so now everyone should see all those builds.

Cool. Good to see all is solved. :+1:

I see everything now. Thanks, Matt.

I deleted the other topic on this matter as it is now fixed.