I found the previous Vital Installer?

I just grabbed a new version and it doesn’t work on Slackware 14.2 despite patchelf-ing around the libcurl issue. The previous version worked just fine.

P.S. good news, at least for me: The link for the zip file ends in the version, so I was able to retrieve a copy of Vital 1.0.3, and I’m live again. Now pardon me while I make a backup so I don’t find myself in this situation again.

I am curious what changed in 1.0.4 that would break things though.

For future reference the old versions are still available to download in your account. They go all the way back to version 0.8.2

The trouble is that it’s not clear. From my browser, there is a single button out of four for that zip with no notion of a version number. I copied and hand edited the link in blind hope that would get be somewhere, and it did, but that was pure luck rather than skill. The previous content might well have had a different hash in the URL or been deleted; there doesn’t appear to be easily understandable public links for previous versions. I’d welcome evidence to the contrary.

Here’s what it looks like in your Vital account “All Downloads” (image downsized to fit here)


All Downloads in the upper right hand corner:


Not on my browser. “Your products” doesn’t even have a region.

What Browser do you use ?

Firefox with some privacy extensions.

The above screenshots were taken using Firefox. It has something to do with your privacy extensions. I have Ghostery enabled and as you can see it does not block any elements.

Try disabling your extensions one by one until you find the culprit.

I was trying that as you wrote. Now I’ve got a hang, but I’m going to try restarting the browser clean.

Tried firefox in safe mode to no avail.

Well there is something in your security settings that is preventing you from seeing the All Downloads link which is:


What version of FF are you using ? You’re on Linux ? I’m on FF 84.0.1 and Windows 10.

OK. I had firefox 68.0, and I just tried 84.0.1 both normally and in safe-mode, and I’m still not getting a product history. I’m running this under Linux.

Did you try to copy/paste the link above ? Works here.

Doesn’t your Linux Distro do updates ? My Kubuntu system does. It may lack a few minor version updates behind the Win version of Firefox but not all the way back to version 68

What is your “Enhanced Tracking Protection” setting in Firefox ? Mine is set to Standard. If you set it to “Strict” it may cause some sites not to load properly.

I did run with your link, and ETP is standard. Same result.
I’m running Slackware 14.2 with a ton of local hacks for music production here. I’m a pretty old school UNIX admin starting with pre-X11 SunOS and BSD, and I don’t like or trust a lot of automagic.

I’m getting a 404 Source map error on the following, but I’m not sure it’s important. I’m not a web guy:


Odd thing is that wget retrieves them just fine.

Can you try a different browser ? Tor maybe ?

Other than that it appears to just be a system specific issue. Older versions are available for download in your Vital account if your system can access the link.

Well, I did get it solved, but manually. I’m not sure how much I really want to dig into web thingies at the moment. Life’s short.

As a joke, I tried with a headless Mac mini that sits on my net, and I saw the same problem with firefox, chrome, and safari. “All downloads” is not giving me a laundry list.

Hi @caowasteland

It’s as simple as clicking on the email menu (top right in your screenshot) and then clicking “go to account” and you will get all available downloads again (from the first one you downloaded to the last available). I assume that the system “hides” your downloads when it somehow knows that you have already downloaded the latest version available (or that you are up to date).

I’m also in Mac + Firefox, and yes I was also surprised today, just a few minutes ago, after my first download that “Your products” and “Your packs” were empty, so i simply tried what i explain here and voila! The downloads showed again. Now i don’t know if it is a bug in the web page software or it is simply AI.

Hope this helps … Cheers! :pray:

Go to account + all products is not doing that. Look, I’ve been messing with and programming computers since 1977, and I’m thoughtful enough to have tried the obvious. The only thing that has worked for me was taking the download link, fixing it in an editor, and pasting it back in the browser. If the website is being clever and excluding the older versions from view, it’s doing me a disservice. Evidently 1.0.4 has issues with NVIDIA cards, and this cleverness denies me the ability to roll back in an obvious way unless I have a saved installer from a previous version.

Incidentally, the Macintosh on which I also tried had not done any downloads of this, so it shouldn’t have had anything to do with client cookies.

“All downloads” doesn’t show you ALL the previous versions of Vital for you to download, ONLY the versions since you first downloaded Vital. Didn’t you notice that it says “YOUR products”? So “All downloads” refers to “All (YOUR) downloads”, i.e.: from the first version you “buyed” (downloaded) onwards. Now if this is a bug or AI i don’t know.

BTW, i don’t know why you had the need to mention that but for your info i’ve been also messing with and programming computers since 1981! :crazy_face:

p.d.: i will install Ubuntu in a VM and will check that it works (or not) also in LinuX.