Crashes Ableton

LOVE this synth, works fine in stand alone. But, when I try to load the VST (2 or 3) within Ableton (suite 10, Mac OS High Sierra) it completely crashes Ableton. I’m still able to trigger sounds in Vital but the DAW crashes. I’ve uninstalled, reinstalled, logged out, logged in, removed the Vital VST files from plug-ins, rescanned etc…any ideas? Thank you

Could you try deleting the files in ~/Music/Vital and restart? I think there was an issue with some corrupted files from failed downloads and that might fix the issue.

Hello, I’ve just tried that. In fact I’ve wiped everything Vital related and re installed and it still crashes when I try to load up the VST in Ableton. Thanks for you help and hard work

What about the AU version?
Just asking… are you sure its latest 1.0.3?

I’ve tried the AU also, as well as VST 2/3, same thing. It’s definitely 1.0.3 as well. I downloaded the installer gain today. I’m trying to think if there is anything within Ableton that could be causing this…

Is it legit or patched version of Live?

Legit, no cracked software

What version of live 10?

Live 10 Suite

Yeah but what version? 10.xxx

Ah right, 10.1.30

Do you have any other DAWs that you could open Vital in?
Also do you have anything that restricts internet access in Live or something that restricts access to the keychain? Might be crashing because of the authentication library.

I’m working on an full “offline” mode so when that’s out would be curious if that works.

I have actually just managed to get the VST3 working for the first time! And the sign in box appeared within Live for the very first time too. Could this have been something to do with wifi vs ethernet? I have no idea why its working now, I’m sure I tried everything. To my knowledge there is nothing in Ableton restricting internet. I did have the screen zoom increased a bit in preferences. So far it seems to be working, i’ll report back if anything changes. I only have Ableton by the way, so not able to test on anything else.

Thanks so much

I spoke too soon, its crashing again now :confused:

Try codesigning the vst and AU. Also what are the specs of your Mac?

Its an Imac Retina 27 inch late 2014
3.5 GHz i5
24GB RAM

I have no idea what codesigning is haha, I’ll look into that now, thanks

Interesting. So it’s crashing intermittently (but usually) on startup? Yeah this might have something to do with the internet connection.

Could you try this: open the standalone, click on the logo in the top left, deselect “Check for updates” and then try and launch Vital in Ableton again and see if it starts normally? If that works (or doesn’t) it would help me track down this issue.

As soon as I load the vst into a new track the interface appears and then 1-2 seconds later I get the spinning wheel and have to force quite Ableton. I’ve deselected the ‘Check For Updates’ and still the same. Tried the AU too and thats the same. Even when I get the spinning wheel and Live isnt responding I can still hit the midi controller and hear sound from Vital…so its like Live is crashing, not Vital maybe

for test purposes i highly recommend hostingAU

http://ju-x.com/hostingau.html

this is a very small, freeware AudioUnit host for Mac OSX
launches extremely fast, loads eytremely fast and
“eats” sotosay anything AU
(exept maybe the very heavy crashers…) :wink:

1 Like

I don’t see a purpose of this if the AU, or VST is crashing. This is a bandaid when they need a solution.