Why does Vital require a sign in on launch?

Absolutely love the synth, but having to “sign in” manually every time I use the plugin? It’s so annoying, I have all but stopped using it. Is this a bug that’s going to be fixed someday?

Part of the reason it’s such a problem for me is, I use the password generator in MacOS, which creates impossible-to-memorize passwords.

So, every time I launch Vital, I have to:

  • open Keychain Access
  • search and find my Vital passwords
  • open the info panel and authorize (with my computer’s password)
  • copy-paste password (and email) over to Vital.

That’s a lot of hoops to jump through EVERY TIME I want to use the synth… is there a fix or a workaround coming? I love the synth and would love to work with it more, but this is turning into a sad showstopper for me…

I’m using a 2017 iMac running Catalina. Thanks in advance for any advice!

1 Like

Oh that happened to me when I first got it, but it stopped doing it after I logged in like two or three times. I think it just might be a minor bug, and it should go away by itself. Keep us updated and let us know if your problem still persists, I think Matt Tytel might know how to fix the problem.

1 Like

Hey, MadR… thank you for the quick reply!

I discovered I was still using v1.0.3, not the latest v1.0.7, so I dl’d the latest, and hopefully it will solve. I’ll report back after I confirm one way or the other.

Thanks again!

1 Like

Np! v1.0.3 was actually my first version too XD. Hopefully it fixes your problem!

Updating to 1.0.7 does seem to have solved the issue for now. No login requests since updating. Great!

Thanks again for your assist, MadR.

1 Like

Hey MadR.
I’m having the same problem as tribalogical with having to sign in every time I open the UI. This applies to both the standalone and VST3 version when opened via Ardour.

The difference between me and OP is that I’m running Debian Testing on a Lenovo L480.

Oh, and I’m running the latest version.

MadR, are you also on Debian or do you use MacOS?

1 Like

Hey Paerox,
I am running Windows 10 on a Lenovo V14.
I found a forum on here that might or might not help, let me know if there’s any
information that might help you on here.

1 Like

A wallet subsystem sounded like a plausible culprit, even though it sounded a bit strange. I enabled the option that prompts me whenever an application wants access (KDE Wallet in my case) with hope that Vital would ask for permission, but that does not that happen in my environment.

I also tried installing Seahorse thinking it would be invoked somehow, but no cigar.

After re-launching Vital and signing in multiple times, I once clicked outside the sign in dialog box by accident and then It disappeared, enabling me to use Vital as normal. Same behaviour in the VST3 version with Ardour as the host.

So, In other words, I think I’ve stumbled upon a bug where the sign in dialog box shows up with empty Email and Password fields, regardless of whether you’ve successfully signed in before. This tricked my in to thinking that my login credentials were not saved and made me believe that have to sign in every time.

Is there a list of known bugs on this forum?

1 Like

Wow that’s funny, so did the sign in dialog box stop showing up now? I don’t think there’s a list of known bugs but there are forum pages of known bugs if you go to categories and click on “Bugs”!

No, the dialog box still shows up.

I’ve done some testing with a simple Ardour project.
It has 2 MIDI tracks and one Vital instance in each track.

When I save the Ardour test project, close it, re-launch Ardour and open up my Vital test project again, the sign-in dialog box is presented with empty “Email” and “Password” fields when I open the plugin GUI and I have to click outside it, within the plugin window, to dismiss/hide it. This dialog box does not show itself again for the duration of the Ardour session.

This behavior is on a per-instance basis (per Ardour track).

My version of Ardour is:
“Old Land”
(rev 6.5.0~ds0-1)
Intel 64-bit

Vital version is 1.0.7-1 (installed from .deb-package)

Just in case it is relevant, I can also mention that I’m running Debian Testing (bullseye/sid) on a ThinkPad L480.
Desktop environment is KDE Plasma on Xorg with a minimal number of apps.

1 Like

I honestly can’t think of any fixes yet. The only things I can think of right now is updating / restarting your PC, which probably won’t work but that’s all I can think of right now XD. I think you might have to ask Tytel or someone else for this one.