Vital requires sign in every load (linux)

On my Linux music computer Vital asks for my password and asks to access a keychain the first time I use it every time I login to my account (every restart).

I’m using Lubuntu ( so an LXQT desktop based on Ubuntu 20.10 LTS)
it’s runs stable after that (especially considering how underspec’d this computer is)
but just annoying to have to log in everytime, haven’t encountered this issue on Mac or Windows.

1 Like

try install gnome-keyring

I doubt the keyring will alter the login request itself. And it appears to be very hit-or-miss
among linux setups, as to who get’s continual login requests that can’t be bypassed.
Myriad conditions for the Vital coder to ponder, hip-waders recommended…
Maybe the 'Check For Updates ’ button should shrink, and be on the main gui?

This has so far been my top annoyance with Vital in my experimentation with it. If I’ve unlocked Gnome’s login keyring, there’s no issue. But if the keyring is locked, Vital always asks me to sign in, and then Gnome’s keyring unlock dialog get’s triggered.

The problem here is that I’ve set my system to log into Gnome automatically on boot, and apparently the keyring doesn’t get unlocked in the process. I wasn’t even aware of this fact before using Vital, because literally no other software I use regularly has asked be to unlock the keyring. Which leads me to question the practicality of using the keyring to manage Vital’s login in the first place… Surely there should be a better way to do this that relies less on external setup?

(Edit: for reference, I’m on Debian testing, Gnome 3.38)

ahhhh yes I am on automatic login as well on LXQT, I wonder if that is the issue.

Erase vital use dpkg to install wait for downloads to complete for new instalation then click install did the same thing about couple of hours ago :smiley:

Reinstalling doesn’t do the trick for me, still asking for password every load

Tried deleting, remove config file, reinstalled let everything download and install

This worked for me on Ubuntu Studio 20.10 (KDE Plasma) but it might works as well on GNOME and other DEs.

  1. Install seahorse (GNOME users don’t need to, it’s already installed)
  2. Open seahorse (Passwords and Keys is its name on application launcher), right-click at your Login keyring and select Change Password
  3. Set the password to empty

This answer on AskUbuntu might give the same result, though I’m not sure. It’s for people who are concerned about unprotected infos:

Ah yes that was the problem
In my case it was not the “login” keyring but the “default” keyring.
But setting it to not need a password with seahorse as you stated solves the problem for me.

LXQT / LXDE doesn’t have anything like that installed by default.

Thanks for the suggestions everyone

1 Like