Vital won't open in Logic Pro - but runs as stand alone fine

Quick question…is there a minimum system requirement to run Vital Pro?

I just bought Vital Pro v1.5…and Logic is not playing nice…it won’t open it. Please see screen grab attached after pressing rescan. But Vital does run fine as a stand-alone app outside of Logic.

It’s possible my system/Logic is too old…and i might need to upgrade. I’m using:

Logic Pro X 10.4.2
Mac OS Sierra 10.12.6

Thank you for any help you may be able to offer. Kind regards, nick

Try signing out an working offline in the standalone

Thanks for the suggestion SlavaCat. I signed out of Vital (chose ‘work offline’). I also restarted my computer. Everything is the same. Vital works as a stand-alone app totally fine. But Logic doesn’t want to know about it. Maybe my system is too old?

Have you tried an older version of Vital, 1.07? There was a graphics engine change that seems to be messing with people.

Thank you. I just installed 1.0.7 again…and Logic is still refusing to play nice.
i actually had 1.0.7 installed first, but then i noticed some patches weren’t working, because they had been made by a later version of Vital (including a patch bank i bought from Eric Bowman ‘Sounds you know’). He suggested i download v1.5…which i did…and all the patches are working. Yay. But then i opened Logic…and here we are. :slight_smile:
I think maybe my MacOS is causing the problem, being so old.
Thank you for your help though.

Im thinking its an AU problem, too bad logic doesnt support anything else.

vital v1.5.3 (and 1.0.7) (AU version) is running fine in logic 10.5.1 under mojave

have you tried other hosts?
like for example
hostingAU or reaper ?

Thanks SlavaCat and muki for your replies.
Yeh, i think maybe my OS (Sierra 10.12.6) and/or Logic Pro (10.4.2) might be the problem. I need to upgrade those…which means buying a new Mac…because sadly, later OS versions (high sierra, mojave, catalina) are no longer available for my model of Macbook.
No…i haven’t tried other hosts. I’m kinda happy to stay with Logic. I’ve invested a lot of time learning it. But thank you for the suggestion.

if you are on a budget you could use opencore to install a newer version of osx on your mac.

meant to be just for testing purposes
esp in re hostingAU
logic can be a little bit picky with 3rdparty plugins…

Thank you lokki for your suggestion. I haven’t heard of opencore…but i’ll look into it.
Thank you muki - ahh, i understand now. I’ll also look into reaper.
You gotta laugh at it all…today, i tried updating Logic, but the app store kept failing. Then i tried reinstalling Sierra several times and it kept failing as well.
I think the universe is trying to tell me something. Maybe something like…take a really long walk, find a peaceful lake and quietly throw my macbook into the deepest part.

Success! I managed to download OS Catalina today…which was a test in patience.
Apple: time remaining to download, about 45 minutes (4.9Gb)
Local telco: ha, ha, ha…no. Let’s make that about 6-7 hours.
But it all worked and at the same automatically updated Logic. Vital has validated inside Logic. So it’s all good. I’m sure it must’ve been something screwy with my particular setup in the OS or Logic. An isolated case.
Thank you for all your help. Much appreciated.

1 Like

gratulations!
and thanks for letting us know :slight_smile:
:clap: