Vital white screen

Hi Vital support,

I’ve purchased Vital pro today.
When opening 6 to 7 instances of Vital in Ableton 10.1.30, Vital shows a white screen when opening the screen. Ableton freezes completely and generates a crash report.
Are you able to reproduce this?


1 Like

It seems that one track / instance of Vital is giving the issue.
E Membrane was loaded and tweeked in a previous session.
After opening my song again in ableton, Vital was not able to load the parameters and shows a blanc screen.
Is there a way I can help debugging this?



I’m having the same issue.

Figured it out! I had to use the vst3 which for some reason was located in C:\Program Files\Common Files\VST3

hope this works for you

Just kidding this somehow only worked once.

[quote=“kiefer, post:4, topic:1689”]
the vst3 which for some reason was located in C:\Program Files\Common Files\VST3[/quote]

“The VST3 format has a dedicated installation path all VST3 plug-ins must comply with.”

“C:\Program Files\Common Files\VST3
32-bit VST3 plug-ins on 64-bit Windows: C:\Program Files (x86)\Common Files\VST3”

My plugins are located in C:\Program Files\VstPlugins and my Ableton is pointing to that location.

It is not like it cannot find the plugin… when opening a saved project and I start the tracks, I 'm getting audio from the plugin. It is when I open the Vital plugin screen itself, it freezes together with my Ableton completly.

Hoping for a solution quickly…


Any solution for this yet? tried reinstalling a few times in different locations

I’m having the problem when moving the Vital Plugin to my second screen.
When I reopen it there afterwards, it is giving the blank screen.

Via procmon I was able to trace a bit when the plugin opens:
I see that it is first loading the Vital presets
Next it is going to NVidia GLcache… there must be the problem somewhere
resolution screen1: 2560x1440, resolution screen2: 1920x1080

Solution for now : keep the plugin on your primary screen. :woozy_face:

Hoping for a breakthrough and a fix soon… :v:

Thanks so much! This seems to be the workaround for now haha, not working on my main screen :raised_hands::partying_face: