Vital Pro fails to load in Logic X

i bought the pro version of vital and now it fails to load in Logic X. I had the free version before and it worked and now i bought it and its not working no more. I can open it as a stand alone but in Logic it always fails to open (Error, also when i rescan it with the Plugin Manager. Can anybody help me with this.

Greetings, Dom

Hmm haven’t heard of this behavior before. Have a few questions: Are you signed into the standalone? Does it download when you start up standalone? Does it show you an error when you try and open the plugin window or when you create the plugin?
Also what version of mac are you on?

thanks for your response. Yes i think im signed in in the standalone, Vital works as a standalone (sound) and yes it also starts to download the additional content (see pic i added). When i open Logic it fails the AU-Validation (see pic) and when Logic is open and i rescan Vital an Error messages comes (also pic). Thanks for your help.

Greetings Dominik

Oh and i am on macOS Sierra 10.12.6. I havent made updates on my mac since i have it - might it be that?


Hmm if it was working before it should be working now.

When you open the standalone can you finish and install the download, then try it again in DAW?

If that doesn’t work, could you try logging out of the standalone version and click “Work offline” on the sign in dialog. Then try again in DAW.

If neither of those work let me know. I’m guessing this is some weird case with that version of mac (the earliest I support). I’ll have to see if I can get my hands on that version to test with.

yea i tried both, not working sorry, i tried it with my friend who has a computer company but he couldn`t fix it either. I could try to update my mac or Logic but maybe like you said you can test it and maybe fix it?

Greetings, Dom