Vital Plugin on Linux not supporting drag and drop of audio files

Drag and Drop works as intended on standalone but on plugin version it does nothing. I tested this with waveform and carla with vst2,vst3 and lv2 format.

OS: Ubuntu 20.10
Kernel: 5.8 Low Latency
Audio: Jack
DAW tested: Waveform 11.2.0 and Carla
Steps to replicate: Open vital plugin, drag a wav file/wavetable to the oscillator
Expected behaviour: It should show importing options (Wavetable, Vocode and another one that i forgot)
Actual Behavior: Doesn’t do anything.

2 Likes

Replicated on linux Mint.

same here using the standalone version, vital crash
Xubuntu 18 04

1 Like

same here can’t import but if you get them
in the right folder, you can load equally well in vital,

avlinux mxe reaper mixbus32c

Not quite sure why this doesn’t work on some computers. Thanks for the report but it may take a while to track this down.

Any update on this? Drag and drop still doesn’t work on Linux in both the VST2 and the VST3 plugin. Using KDE Plasma 5.21 and any host I’ve tried with (Bitwig, REAPER, Carla, Ardour, Renoise). Vital’s main Window does have XdndAware set (but to 3 instead of 5 for whatever reason), but even though it accepts the drop it doesn’t do anything with it.

1 Like

Just for reporting, drag-and-drop audio files to sampler, after some testing:
Vital 1.0.7 VST3
Ubuntu Studio 20.04 (XFCE window manager)
NVidia GTX 1080Ti with 460 proprietary drivers

in Vital standalone, it works.
in Carla, not working (nothing happens)
in Reaper, not working (nothing happens)
in Ardour, not working (locked up whole computer once, other times nothing happens).

2 Likes

With which plugin format, in which host, and on what desktop environment or DE?

EDIT: Thanks for elaborating! :grin: I already assumed you that were trying on the standalone version (since it does work there).

EDIT2: Also keep in mind that drag and drop will not work under REAPER no matter what because REAPER’s FX window had the XdndAware property set and thus steals the drop before it can reach the plugin editor window. I put an option to hack around this this limiation in yabridge, but I would of course not recommend doing this by default in a plugin.

1 Like

Yea, easy to forget the details - but important. I wonder if Tytel is coding and debugging the different platforms himself? That just seems to be too much…

By the way, some people mention a VST2 version, I don’t think I have seen that after my installation?

The .zip archive contains a standalone version, an LV2 version, a VST2 version, and a VST3 version.

1 Like

Oh, I have to try it out then, thanks :slight_smile:

Is there a way to import a file without drag n dropping as a workaround to this issue ?