Vital not working on muh Reaper Linux via Manjaro

Vital on Windows 7 was fine, Vital on Wine on Manjaro is fine (after changing the OpenGL version String)

However, for the past week or two I have tried every day to get Vital Vst3i Linux, Vital Lv2i, and Vital.so (Vsti) to work in Reaper-Linux.

If I use the VST3i or the LV2i, Initiation of the plugin takes quite a pregnant pause. After loading, and after some rather short amount of time Reaper will become unresponsive. Rescaling the plugin will cause a crash, closing a floating window may cause a crash.

one odd thing though, Vital-windows won’t work via Yabridge in Reaper-Linux but it works in WINE, so maybe it’s due to the linux version of Reaper.

The other .so file in the Linux installer (non debian) I assume is a VSTi (vst2) scans but is not admitted into the list of available plugins in Reaper-Linux.

My graphics processor info:

Graphics:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
vendor: Micro-Star MSI driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:0412 class-ID: 0300
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
loaded: modesetting unloaded: vesa alternate: fbdev display-ID: :0
screens: 1
Screen-1: 0 s-res: 3600x1200 s-dpi: 96 s-size: 952x317mm (37.5x12.5")
s-diag: 1003mm (39.5")
Monitor-1: VGA-1 res: 1680x1050 hz: 60 dpi: 99 size: 433x271mm (17.0x10.7")
diag: 511mm (20.1")
Monitor-2: HDMI-1 res: 1920x1200 hz: 60 dpi: 94 size: 519x324mm (20.4x12.8")
diag: 612mm (24.1")
OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
v: 4.5 Mesa 21.2.3 direct render: Yes

I’ll come back with some log info if that would be helpful. Surge L2Vi has also behaved similarly so I don’t think this is all Vital’s fault, but it seems that there’s some truth to the reports that some users on Linux are having issues with Vital.

here’s some logs, taken while using Vital Linux VST3i 1.06, 1.07 and 1.08 in Reaper-Linux 637 or 636:

1.08

X Error of failed request: BadDrawable (invalid Pixmap or Window parameter)
Major opcode of failed request: 14 (X_GetGeometry)
Resource id in failed request: 0x5000098
Serial number of failed request: 18537
Current serial number in output stream: 18537

1.07

libGL error: failed to create drawable
libGL error: failed to create drawable
X Error of failed request: GLXBadContext
Major opcode of failed request: 152 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 165
Current serial number in output stream: 170
X Error of failed request: BadImplementation (server does not implement operation)
Major opcode of failed request: 20 (X_GetProperty)
Serial number of failed request: 170
Current serial number in output stream: 170
free(): invalid pointer

1.06

reaper_host_x86_64: xcb_in.c:746: xcb_request_check: Assertion `!reply’ failed.
Xlib: request 20 length 24 would exceed buffer size.
corrupted size vs. prev_size

These are the typical sort of errors I’m seeing when using only Vital VST3i Linux in Reaper Linux. Could be my system, could be Reaper’s fault, could be Vital, could be user error. But Reaper is freezing and “terminate plugin now?” dialogue is coming up sometimes, other times hard crash.

Hi.

I post this issue many weeks ago and nothing changed (and probably it will not change in future). In my case Vital work only if there is 1 track in Reaper. If I load another, then it crashes. Slowly I’m thinking about buying another synth - maybe Zebra or TAL Mod, which demo versions have no issues in every version of native Reaper I’ve tested. It is ridiculous to use Vital through Wine if we can work in native Reaper.

Best

1 Like

super edit: try this if you have a problem running vital in Reaper…

in reaper-linux, run vital as “Native Only - No Bridging” by right clicking the plugin in the plugin browser.

Vital’s been crashing reaper like crazy until this.

Yeah, Linux distros and DAWs are kind of a lost cause. And the universe knows I tried hard. I capitulated and bent over for windows. My producer life is better since. In the end it’s a matter of taking the blue pill vs dying from ‘bug vortex’ induced seizure.

1 Like

administrating a linux pc is a full time hobby in of itself! if I wasn’t such a deadbeat with all the time in the world to kill i wouldn’t have time to have set up my workstation every day for 6 weeks. :slight_smile:

1 Like