Vital is requiring OpenGL on Cakewalk?

Hi guys! I just fresh installed windows on a new hard drive. I finished installing all my drivers, including the Radeon software. The standalone version of Vital works fine. Any step I am missing?

Edit: It seemed that the standalone didn’t work as well, but then I realized that this only happened when I switched to power saving mode on my laptop. So I tried to switched back to performance mode, and Vital worked just like it should. Probably my power saving mode is disabling OpenGL, thus making Vital not work?

From the Vital site:

System Requirements:

64 bit only
OpenGL 3 or higher

Don’t know why I’m not getting the right OpenGL version from within cakewalk. Does the regular VST work?

it’s probably not a problem with Cakewalk, i think. It’s the same with the standalone vital. My openGL version is not recognized on power saver, when the system uses intel graphics. But on performance mode, with discrete graphics, vital works like it should. I’m trying to reinstall my intel graphics driver right now, checking if the problem is with the driver.


Woah I think I found the problem. I just downgraded my intel graphics driver from “Intel Graphics Command Center”(new) to “Intel Graphics Control Panel”(old), and now Vital works without OpenGL errors. Maybe the newer Intel driver is to blame, I’m not sure. But I’m seeing a few others with the OpenGL problem like mine, so the downgrade might just be the solution.

Just for the record Vital works fine here in Cakewalk in two systems one running older Intel onboard and one running an Nvidia 1050ti. Both Windows 10.

1 Like

Hmm interesting, thanks for the update. Not sure if that’s my issue or Intel’s but I’ll look into it if I can figure how how to set that up on my computer.

1 Like