Vital invisible screen issue?

At first, Vital always works in a project for me, but eventually bugs out and wont show at all anymore. I feel like it may be a rescaling issue but I’m not exactly sure because it never occurs when I rescale the plugin. This is in FL Studio and has been happening for months now.

I have never seen that or anything like it. In Cubase, if something like that happens it can sometimes be corrected by resetting the Cubase Preferences, perhaps FL studio has a similar feature?

1 Like

It happens to me on reaper/linux. When I open more than 1 instance of vital then reaper freezes and the only way is to kill it. I posted this issue few days ago but without any help.

1 Like

What are your scaling settings in FL Studio? In Windows?


Are you using the VST 2 or VST 3 version? I’d advise using the VST 2 version for now.

1 Like

Thanks for the reply, I’ve looked for a similar feature but nothing still worked.

My FL settings are pretty much the same with 139 PPI and for Windows 10 it should be at its default state. I believe I am only able to download the VST and VST 3 versions and I use both.


[quote=“dorianicardenas, post:6, topic:7446”]
My FL settings are pretty much the same with 139 PPI[/quote]

Is FL Studio’s scaling set to “advised scaling:100%” ? Are your FL settings “Pretty much the same” or the same? Can you post a screenshot? There is some reason why you’re having the issue and others are not. It’s just a matter of figuring out what is the reason.

I don’t know if you are referring to the main GUI scaling (I use System scaling) or Legacy scaling (Main scaling). I also just now tried the 150% scaling GUI which fits nicely, but I don’t think it worked. I’ve also uninstalled, removed all Vital components, and reinstalled it many times which obviously didn’t help at all.

Hmmm I don’t see anything that jumps out at me as a possible cause. You say it works but then “eventually bugs out”. Is there anything that seems to trigger it bugging out?

Can you reproduce the issue reliably? If you can upload a project that only has Vital in it where it has bugged out I can try loading it here and see what happens.

You say this happens with both the VST 2 and VST 3 versions? Are you logged in to your Vital account or working offline?

For the record I don’t get the same issue here so there’s something different going on between our systems just have to figure out what’s going on. I do have “use fixed size buffers” selected in the wrapper settings. Maybe you could check and see if that helps.