Unwanted pluck sound at beginning of long attack patch

Hey there,
I’m experiencing a strange issue with a pad I wanted to create. No matter how long the attack time and even with a delay on the envelope, I’m getting a pluck of one or more notes at the very start of my MIDI, before the envelope actually starts to rise. So far, it didn’t happen in standalone mode but only in Logic.
Does anyone have a clue what I’m doing wrong?
I am using Logic Pro 10.7.4 on a Mac Mini M1 (2020), macOS Monterey 12.5.1

Uplaod the patch

Here it is (couldn’t upload it directly because I haven’t been very active round here)

Is it a filter envelope jumping closed/open perhaps?

Unfortunately no, I have almost nothing activated on the patch. Only a saw wave with a delayed envelope and very slow attack :confused:

I can’t get a click or pop in Reaper (Windows)
What plugin format are you using? Try switching

Thanks for trying it out!
What exactly do you mean by “plugin format”?

vst, vst3, AU?

I was working with AU but now tried the other two and still no difference.
I think it might be most likely a MIDI problem because I have drawn the notes in and the sound I hear in the beginning is always one or more of the drawn in notes. It is as if I’d hear a pluck of my actual notes but right at the start, before they’re supposed to be heard. Also, it doesn’t happen consistently every time I press play but only every few plays. I thought it might be some MIDI notes that are still sending when I press play again, but even then I’m not sure why they aren’t muted by the envelope. Any ideas?

Do you have a long release on the envelope? If so the first play when you open the project should always be good…

Subsequent plays could have a popping sound, if the release phase had not been finished.

Other than that, maybe some unwanted midi learn is active?