UI glitch (Vital unusable)

Hi there, I’m here to report a bug.

I am on macOS and I have this strange interface glitch making vital unusable. Here you have a screenshot to know what it is about.

Am I the only ?


See if you have GUI scaling set to anything other than 100% in the DAW you are using. Set it to 100% and reload your DAW. If this doesnt help try check the desktop scaling settings of your OS and set them to 100%.

This is what mine looked like on PC with FL Studios’ GUI scaling set to 125%. I set the GUI scaing to 100% in the DAW and now it appears fine.

I am the same issue with both standalone version and ableton, have you solved?

Same issue with Windows 10 in FL Studio…

When opened for the first time (as a new instrument on the channel rack), it looks fine, but after closing (minimizing) the window the GUI is glitchy.
In addition, auditioning a preset by keyboard playing isn’t working (it does work with other VSTs).

I tried resizing by clicking on the logo and also tried setting FL Studio scaling to 100%.

Hoping for a fix soon. // still love the VST …

Yeah I’ve got a few screen resolution issues to work out (there are a few threads of this is the forum). A lot of people are using Vital find in Logic and FL so I need to track down exactly why it’s only happening on some user’s computers and not others.

1 Like

No problem. All the best with the solution.

I use Ableton 10.3 on Mac OSX 10.15.1 43

and a Acer SA220Q second monitor with this specifics: 55CM (21.5") - 16:9 - Full HD - Maximum Resolution 1920 x 1080 - Brightness 250 cd/m².

When I put Vital on the second monitor I see like this

If it helps, I was having the same issue a while ago with Helm so maybe it’s something with JUCE? Idk I’m only a novice at plugin development right now.

no graphic probllems here on mac os x mojave, standalone and LogicProX10.5.1
on a mac mini 2012 i7 (Intel HD Graphics 4000 1536 MB, metal capable)

I’m dealing with the exact same issue, @Slashead. Identical looking screen.

Macbook Pro (2019)
Catalina 10.15.7
2.3 GHz 8-Core Intel Core i9
32 GB 2667 MHz DDR4
AMD Radeon Pro 5500M 8 GB
Intel UHD Graphics 630 1536 MB

Today I try to use a Philips tv monitor and with it I don’t have issue, it fixed perfectly.

I’m getting this problem as well. Good luck man can’t wait to use the synth

It happens if FL Studios’ main GUI scaling is not set at 100%.

I’ve already responded to another post about this same thing happening on an external 4K gaming monitor for my 2019 16" MacBook Pro. I keep seeing this same problem from others… Has there been a response to it that I can’t seem to find? Looks/sounds like crickets - silent.

not happening here: logic 10.6.1, on big sur 11.1 no GUI weirdness in the standalone OR as a plugin in logic…

Alright finally got to reproduce this (specifically the mac issue). I have a fix that’s coming out in the next version after QA is done.

Until then I think you can fix this on the new monitor by resizing the plugin screen. It’s a bit hard to do because the graphics are all shifted but if you click in the top left where the logo should be and then near center where the resizing buttons should be you can resize it that way. Or just wait for the next build which I’m aiming to release this week.


Thanks Matt!!


Sounds like you’re on top of it but if it’s any help for debugging or whatever, I’m on Catalina and both AU and VST exhibit this behaviour in Logic, Live and Maschine. That is to say on the on the lower resolution of the two monitors it always shows the glitched UI, regardless of which one is set as the main monitor in system display preferences, and where the DAW is running.

Also on both monitors an attempt to resize by dragging the handle allows a downward resize only but not an upward one i.e. you can only make it smaller rather than bigger.

EDIT: you can indeed fix it as Matt says by guessing where the buttons would be for resizing on the glitched UI. Oddly once this has been done you can drag back and forward between monitors with no issues.

Hope this is some help.

Another way I managed to solve the problem was by moving the plugin window from my extended display onto my MacBook display

This should be fixed in the latest at https://account.vital.audio - version 1.0.4