Trying to make LFO loop no matter if Note ON event received from DAW

I don’t want LFO loop to reset on new notes. I see Loop Hold option in LFO, but I don’t know how to use it, if that is what I need at all?

Also I tried using LFO modulator from the Bitwig studio, to modulate LFO Phase on Frozen LFO, but it still resets… (actually does not reset but acting very weird…)

I guess many of you were here, it’s probably that I’m just not getting it, but endless LFO loops are quite fundamental thing, I would be surprised if it’s not possible… Thanks!

1 Like

Hi! Welcome to the Vital community!
Try changing the mode of the LFO from Trigger (the default one) to Sync.
This should solve your issue.
If it doesn’t, kindly explain your issue once again so that I’ll be able to help

1 Like

By setting the LFO to sync, like dj.n971 said, the LFO will continue where it left off when a new note is pressed. If you want to have this the LFO to continue while not pressing a note, you will have to send in a 0 velocity note from your DAW

1 Like

Thanks guys but this didn’t help… Maybe I didn’t explain my problem well, here I will try it again in more detailed manner. So I’m playing one loop comprised of several clips in Bitwig studio. In one clip, I’m using Vital and the whole clip is filled with one note placed at the beginning which naturally gets sent again when clips starts over from the start. I use LFO to modulate some parameter, but I don’t want LFO to reset when note is sent again. Neither Trigger, nor Sync settings help. Triggers starts LFO over, and Sync also restarts LFO, but from the second “bar”, if you get me. Usually, in other synths its called Freesync or Free mode, where LFO is independent from DAW (actually starts only on 1st note, but it never ends or resets).

Hope you’ll be able to help me now, thanks again!

1 Like

The Sync LFO is supposed to be exactly like a Freesync / Free mode / Free run LFO.

The Sync LFO should run forever without resetting, even through every note and clip, unless you loop back to the beginning of your song in your DAW.

Would setting the LFO Frequency to Tempo Mode and setting it to a longer Frequency such as 4/1, 8/1, or 16/1 help or does it still not solve your problem?

In your DAW, does the Sync LFO reset on every clip you placed?? Because in my DAW the LFO does not reset or start over on every clip, it continues as it should. It might be a DAW problem.

I suppose they Freesync LFO mode keeps changing its name, and is Sync in Vital. In Surge, for example, its Freerun

Can you, maybe, record yourself explaining the issue? Looking at your project might help understand ur problem. There might be some problem other than Vital, so maybe a quick look would help.

1 Like

Tried recording the whole session so you can see but I had no quick luck… Anyways, may be the problem with Bitwig studio, but it does reset LFO every time clip is starting over, which is not the case when you play from arranger - but there some different problem happens - the moment LFO needs to return to first position to start the loop again, it goes right in the middle of it, not to beginning. Also, LFO resets when ENV1 end is reached and I see no real way to even turn off ENV1, it’s always applied right, and we’re actually constrained with the maximum duration of one note, right?

1 Like

May we see a screenshot of the arrangement where you used Vital?
As well a screenshot of the LFO?

And the Sync mode LFO should not reset if even if the ENV ends. The LFO’s position should follow the DAW’s global tempo at all times.

1 Like

Yeah, a look at your arrangement would help us…
And Sync LFO works exactly the way you want it to… I’ve tried it too, it works fine…

1 Like

I think I figured out your problem!

What you want to do is

  • 1: Set your LFO to Trigger
  • 2: Set Voices to 1
  • 3: Set the Synth to Legato in the bottom right corner

Now when you play different notes without releasing it will not reset the LFO unless you stop completely. I hope this helps! Let me know if this was the solution you needed.

1 Like