Subscribed; TTWT can only say "Text to wavetable"

I subscribed to Vital in order to use TTWT, which appears to be unavailable in the free and basic versions.
I have seen videos of the feature working! But it isn’t working for me. My experience:

  • Load the preset Text to WaveTable Template
  • Rightclick in the OSC-1 pane, choose “Text to WaveTable” from menu
  • Type in some text [*], such as “4321”, “check-1-2”, “nothing”, “SheNoWork”, etc.
  • Hit Enter
  • Play keyboard.

All I hear is “text to wavetable”, NOT ONCE my typed-in text. Huh, wtf?

[*] Re typing in text, the space character is not allowed?! Seriously? (Typing it does nothing, it’s suppressed.) How does the TTS service/engine know where syllable boundaries are, and why are you making it figure that out (probably wrongly some of the time)? A great inconvenience for the user, with no discernible advantages.

Reaper 6.18 on MacOS 10.14.6

Feature request: documentation.

Thanks in advance!

For the record TTWT also works in the Basic version. I can’t say for sure it works in the free version but I think it does.

Try starting with “Initialize Patch” and try typing your text there. TTWT has always worked for me no matter what I typed including space but I’ve never tried special characters.

I’m on Windows so can’t say if it works on Mac as well but I haven’t seen anyone else reporting the same thing you are.

EDIT: I just tried using the Text to Wavetable Template and it works fine there too.

OK I tried it in Ableton Live Lite v10, and it works properly (I can enter spaces, I hear the text I’ve typed, etc.)

Before that, I tried your approaches in Reaper [latest version, 6.18], and no change: entering text had no affect on the sound, and I couldn’t enter spaces. Just whose bug it is, I’ll leave to you to sort out :slight_smile: But I expect Reaper support matters.

At at there’s a matrix of Vital-versions vs features, but it says nothing about the TTWT capabilities of the Basic and Plus versions. I tested Basic in Reaper, lol, where it doesn’t work, & inferred it wasn’t supposed to. Is there a limit on TTWT usage in those versions?

Edited to add: Thanks for the quick reply, and for the great work/great synth & UI.

Hi @twangist, I’m sure I read at some point that the Pro version had “unlimited” Text to table conversion, and that the Plus version was limited to 5 runs per day. Not sure if there was a statement about the free version.

@twangist try my TTWT presets TTW - basic.vital (221.2 KB) TTW - Mushrooms on.vital (221.0 KB) TTW - Om Shiva Boom.vital (1.3 MB) TTW - this is a fucking alien.vital (248.6 KB)

For the record I have tested the TTWT function of Vital in Reaper and it has always worked since day one. But again that’s on Windows.


I don’t doubt your successful experiences with TTWT in Reaper on Windows :slight_smile: But it isn’t working on MacOS 10.14.6, the latest version you can run without losing all your 32-bit apps.

On MacOS, Reaper’s (computer) keyboard handling in edit fields feels non-native, it doesn’t see certain combos e.g. prev/next word (Option + horiz-arrows). I just remembered: Reaper/Mac also ignores space char in other plugins, e.g. Kontakt player, so that is their bug.

Is anyone else who is using Reaper on a Mac having the same issue ?

Edited & emended:
On 12/25, “miraculously” Vital TTWT worked just fine in Reaper 6.18. On 12/26, after closing & reopening Reaper, it again does not work, in the ways described. I found I can enter spaces with Shift+Space, but it’s moot because Vital (1.0.3) doesn’t change the wavetable after I hit Enter. FYI when I hit Space while typing a phrase into Vital, it gets passed through and the project starts playing – just would happen if Vital weren’t open.

I just installed Reaper 6.19, no change.

Did you try selecting “Send all keyboard input to plugin” in Reaper ? I just tried again here and TTWT works fine in Reaper but I’m still on 6.18

The Space bar doesn’t start/stop Reaper’s transport when Vital’s TTWT window is open.

You can also look in “Show Action List” to see what keys are bound to what action.

That did the trick, thanks. I knew there was such an option, & thought about it, but wasn’t sure it was the culprit, because I had this option UNchecked when things started to unexpectedly work properly. I changed no options/settings/prefs between when it worked and when it resumed failing.

For the benefit of anyone else who gets tripped up by this, let’s mention that in Reaper 6.19 & presumably earlier this option is nontrivial to find: it’s in the context menu of the FX window, apparently only – not in Preferences and not in the main menus.

1 Like