Shepard Tone Click


I’ve encountered an issue trying to use the Shepard Tone feature.

It clicks at the end of each cycle. I’ve checked all the parameters that could be possibly causing the issue, and also tried different wavetables but still get the same click occurring.

Matt if you or anyone else can check this patch and tell me whether it is repeatable on other machines or whether it is specific to my machine, it would be greatly appreciated.

Shepard Tone Click.vital (971.0 KB)

Yes, I hear the click, which can be removed by reducing the sharp step of lfo2.

1 Like

It has to do with phase.
You set it to 0 degrees, but when the modulation of SHEPARD TONE goes around, the amount of change in amplitude is large.
If you set it to 180 degrees, the amount of change will be small.

You might want to reduce the Smooth parameter of the LFO to absolute zero: it might seem counterintuitive but Shepard Tones depend on a very accurate transition that this might be impeding.

1 Like

Thank you panasony :slight_smile:
It was definitely the phase set to 0 which was the big issue, I knew I must’ve been missing something simple right in front of my eyes. Setting the phase to 180 and the cycle is a nice smooth transition.
Greatly appreciate the help.

I didn’t realise I had the smooth function active on that patch, I meant to have it disabled.
Thanks for your input :slight_smile: