Right Clik Popup Menu Issue with Studio One 6.5

Upgraded from Studio One (S1) 6.2 to 6.5 last week. After doing so, the right-click menus in Vital (1.0.7) do not work right within S1. Still do in another DAW and stand alone. They worked on S1 v6.2. When I right click, the menu pops up, but when I try to click on an item from the popped-up menu (any popped-up menu) it acts as if the pop up is not there. It clicks on what is behind the pop-up menu (again as if it was not there). I raised a ticket with Studio One but this only seems to affect my Vital VSTi (not other VSTi s I have - I tested them). They suggested raising a ticket with you. I know it is because of some change on the S1 side since that was the only thing that did change. But it is also only affecting this VSTi. So, it is a bug at some intersection of S1 and Vital’s code.


Happens to me too. I’m using the 1.5.5 version.

Same here - Studio One 6.5 w/ Vital 1.5.5 - Windows 10. Main-Menu any popups aren’t working anymore…

I tested further and I do not have that problem with other VSTis in S1 6.5. So, it is not a comprehensive problem in S1. But it is a problem somewhere between S1 and Vital (either 1.07 or 1.55). Connected to some change made in S1 6.5 – since it worked in S1 6.2. Seems Vital was “OK” but perhaps not fully compliant UI-wise and the S1 6.5 changes exposed the issue.

PS. I tried VST2 and VST3 and multiple versions of Vital (1.0.7, 1.0.8, 1.5.5). Same issue across all.

Same issue for me. I tried to import a vitalbank file and it does nothing. Changing filters type dont work either.
My specs: Win 10, Studio One 6.5, Vital 1.0.7/1.5.5 (tried both same thing).

Also having same issue with windows 11

Same. Tried different versions, formats, nothing works. Can’t click to change any of the settings (menus such as the voice, display, and matrix).

I’ve the same issue under Phaseplant using popup menus. I can open it, choose an item, but can’t select it using the left mouse button. As a workaround, I can use the arrow keys and enter (in PP) but this doesn’t work w/ Vital. I’ve already contacted the support of Kilohearts yesterday and wait for an answer…

Update - Just upgraded to Studio One Win x64 (Built on Oct 27 2023) the problem is no longer there. Right click menus working again when used as a VI in Studio One.

P.S. I followed up on my original ticket S1 (that support closed) suggesting they be less quick to dismiss well described issues like this.