Preset location on Windows is not good for me

On windows, the Vital preset folder path is: C:\Users\name\Documents\Vital\User\Presets

I don’t have space on my C: drive for wavetables. It’s a small SSD and there’s just no extra space for content.

I’ve seen other posts about this, so I tried using a symlink for all the preset folders by doing the following:

I dragged all the content that was in Presets to a folder on another hard drive and called it “Presets”
I created a symbolic link to that and dragged that into the “User” folder and deleted the original folder “Presets” that was on the C: drive. That way the only “Presets” folder was the symlink. Closed and reloaded Vital and it’s not seeing the content. Probably because it’s a soft symlink and I need to create a hard symlink. Anyway it’s a little unwieldy there must be an easier way. Can Vital be “taught” to view a symlink as an actual folder?

for wavetables and samples you can use add folder, use right click on the name.

can´t help with the symlink.

as a workaround maybe create a big bank and import it.

1 Like

thanks,

right click on the name of what? I’m looking for ‘add folder’ and I’m not sure what function you mean, whether you’re talking about Vital or Windows. I don’t see the ‘add folder’ function in Vital.

By the way, I’m not really asking for support as I have only tried vital out a couple times, not good enough at it to use it in a song yet.

Absolutely and totally unofficial, but working:

  1. Stop Vital

  2. Copy all files from C:\users\YourUserName\Vital to any folder you like (example: D:\music\Vital)

  3. Rename the old Folder (e.g. Vital.old)

  4. Go to %AppData%\vital and create a good backup of Vital.config

  5. Open Vital.config
    It looks like this (that is mine):
    {"authenticated":true,"author":"SerErris","check_for_updates":true,"data_directory":"C:\\Users\\chris\\Documents\\Vital","synth_version":"1.0.5","window_size":0.9071428179740906,"work_offline":false}

  6. Change the data_directory entry to D:\music\Vital. Ensure you do a double backslash on every slash in the path. It should look like this afterwords:
    {"authenticated":true,"author":"SerErris","check_for_updates":true,"data_directory":"D:\\music\\Vital","synth_version":"1.0.5","window_size":0.9071428179740906,"work_offline":false}

  7. Start Vital

Now you should have still access to all patches/wavetables etc. but moved the folder somewhere else

2 Likes

ah, ok, looks cool. I imagine this is a no brainer update in the future, but workarounds are always good. Thanks.

BTW: The add directory feature is here:

Click on the Wavetable Name (e.g. Init) and then in the browser find it in the Folders at the bottom. Click on Add Folder. That is esp. useful for Wavetables, because they can get pretty big.

2 Likes

i pointed the “add folder” to the preset directory and it found the wavetables interspersed in that file structure. cool!

@reklamchef I see you already got help from @SerErris :purple_heart:

Anyway Vital let you choose folder for your stuff when you run it for first time so in future you can change it by renaming the Vital folder to something else, reopening Vital and letting it download content - then choose folder in the dialogue that pops up there (by pressing on the directory location itself, it will open another window), that way you should be able to set different directory for all stuff. Now after Vital downloads everything for you, you can copy your patches there or replace whole directory with your previous one. ^.^

No need to mess with symbolic link. You can also manually move the folder location by editing mentioned config file and replacing the directory there

2 Likes

I have never recognized this … maybe I need to do a reinstall and pay close attention to the installer :slight_smile: