Not showing up in Ableton after upgrading to Monterey OS

The standalone version is working, but Ableton cannot find the VST or the VST3. It worked with Ableton while I was on Big Sur, but once I updated to Monterey and started using the Universal macOS version of Ableton (it was running on Rosetta before), Ableton couldn’t find it. Any ideas? Thanks


I’m using macOS Monterey 12.2, Ableton Live 11.1, and Vital 1.0.7 on a MBA M1.

1 Like

I’m also on MBA M1 with Ableton 11.1 but haven’t upgraded to Monterey yet - I’m afraid it would ruin things :stuck_out_tongue: will be interesting to read replies here…

HAHA yeah maybe hold off on upgrading for a bit… I upgraded because Ableton just came out with native M1 support and Monterey support.

1 Like

From what I’ve read, there are two things different in Live 11.1:

  • Intel-based plugins will not show up unless you run Live using Rosetta (ctrl-click Live and click a checkbox to do this). So I guess Vital isn’t shipping M1-native or universal yet. You’ll have to run Live using Rosetta if you want to use it. This goes for a lot of plugins still, including Native Instruments Kontakt Player, but there are threads on forums elsewhere reporting new M1-native plugins weekly from all different publishers.
  • The application will open before finishing scanning all the plugins - this is different from before, where you waited watching the splash screen while all plugin folders got scanned for changes. This might mean that some plugins don’t show up until a few seconds after the app loads.

Can confirm that Vital is still compiled for Intel only:

$ file Vital.vst3/Contents/MacOS/Vital
Vital.vst3/Contents/MacOS/Vital: Mach-O 64-bit bundle x86_64

This makes it officially unusable in Ableton 11.1 going forward. The tools have been there for over 2 years to mac a universal binary. Will it ever happen?

1 Like

As Ableton Live 11.1 is now Apple Silicon native you have to run it in Rosetta mode so it supports non-native VSTs like Vital

Thanks, all! I knew it probably had to do with me upgrading to Ableton macOS Universal, but I wasn’t sure if it was that or upgrading to Monterey. How do I run Ableton on Rosetta without reinstalling the Intel version of Ableton? Thanks. @michael1 control-clicking doesn’t give a checkbox… Not sure what I’m doing wrong?

Google is your friend… :wink:

1 Like

Indeed and thanks for adding this link to the thread. This is what I’m doing, and it works. Running Vital (Intel-only) on Live 11.1.

For me, I think I’ll be using Rosetta for my DAW for a while still.

Here is the M1-native plugin tracking thread I mentioned. Hope to see Vital end up there someday.