Noise / Distortion when using patches

I’m loving all the patches Vital provides but I’m getting a lot of fuzz / noise / distortion in pretty much every preset.

I’m running a Casio CTK-720 MIDI out into my PC via USB and can’t figure out why there is distortion on almost all of the presets.

It’s especially bad with more than one key pressed or when hitting keys in rapid succession.

I suspect maybe the input signal from the Casio is too high / low but I can’t find any settings to adjust the level from the keyboard as most functions (like volume) are disabled while in MIDI mode.

I’ve tried different USB ports and even tested the same setup on another interface (S*rge) and am not having the noise with the other interface.

Is there a global setting in Vital I can adjust ti remedy the fuzz / noise / distortion I’m hearing?

Thanks in advance for your help,

I’m running Windows 10.

Where are you running it from? standalone, or DAW? What DAW, what plugin format?

I’m running it as a stand-alone and I’m recording it using Audacity.

i suspect that this “noise…distortion” is some kind of CPU overload
can it be ?

does it sound like hard crckling?
and the more notes you play the more and wilder crackling/distortion?

try to increase the buffer size and/or reduce the samplerate…

doesn’t audacity support plugins ?
running vital in standalone and recording it in audacity is maybe not so good…
maybe also a khz mismatch between standalone and audacity…

I tried increasing the buffer (quite high) and set the sample rate to 1X but it didn’t help.

Additionally, any tweaks I make reset to defaults when I select a new preset.

Is there a way to get global settings, etc to remain intact when switching presets?

The crackling is happening with the more notes and the more rapid you press them but it can also occur with single notes depending on the preset.

It is a fairly old Dell Inspiron so it could very well be CPU overload but is there a fix to that other than those mentioned?

The fuzz / crackling is happening without Audacity.

Audacity does accept plug-ins but effects only, no standalone VSTs (unless I’m wrong and Audacity could open Vital but I’m pretty sure it won’t)

Thanks for your help everyone.

You guys are much nicer than those jerks on Reddit lol (just kidding but not really)

i’d try to play vital as plugin from within a host like a DAW
ableton, cubase, reaper, bitwig would come to mind…

there are also free mini “vst hosts” like

VSTHost for windows

hostingAU for mac

if you could upload a mini-little example of a recording of the “distortion”
we might be able to distinuish, if it’s audio-distortion or cpu-overload

what does the volume meter at the top right of Vital look like when you bang on your keys? it could be that the presets you’re using are a bit too loud and are hard clipping at the sound card. a solution could be to turn down the volume at the top right of Vital if that meter is turning red and save the preset. I think Vital could use a limiter option for the main output for this reason.

Audio Sample

Here is a sample using a preset called PD-Dwarfs

It’s three keys in a row slowly and the clipping starts on the third note being held at the same time then I switch to one key in rapid succession

The output meter at the top right never goes into the red or past the white arrow limiter below the visual meter of the output



to me, this definitely sounds like cpu overload

Is there anything that can be done to compensate for this CPU overload?

I’m on a very tight budget and can’t upgrade the PC hardware at this time.

I’ve got Reaper installed now and it seems to offer more controls for Vital but adjusting the volume isn’t taking away the distortion.

Any settings in Windows maybe that I could tweak?


imho this definitely is not a “musical” overdrive distortion but definitely a cpu overload
to me that’s the classic cpu crackle

what you can do is:
a) obviously a newer stromger system :wink:
b) increase audio-buffer sizes
the more buffer the more latency (not funny to play in realtime) but the more time the cpu has for processing the less crackle
c) decrease kHz samplerate
for example 96kHz is a lot more demanding than 44.1

i’m a mac guy - so i can’t help you with wintel tipps

do you already use the asio driver for your soundcard?

I just downloaded the ASIO4ALL driver today and that seems to be doing the trick along with lowering the sample rate and increasing the buffer.

Looks like I’m out of the woods with this issue and the problem is solved.

Thanks for your help everyone!

Now I’ve got to try and get the hang of using Reaper.

Audacity seemed a lot more straight forward in terms of selecting, copying/pasting, repeating track segments to complete songs etc but I’m sure I’ll figure out the nuances of Reaper once I get certain settings working like I’ve become accustomed and familiarize myself with the basics,

Being able to incorporate VSTs is opening up a whole new world.



iirc reaper has a cpu meter which should give you some info about
how hard the cpu is stressed