Modulatin Amount Inverts

I have been using V1.5.5 in both stand-alone mode and as a vst in Reaper 6.73 and Ableton Live 11 on Windows 10.

If I route an LFO as a mosulator to an oscillator level and set the value to 1.000

afer a short amount of time the value inverts to -0.952 thus retaining the level at zero.

This has happened on a number of patches that I was developing. As an interim fix I have uninstalled v 1.5.5 and reinstalled 1.08.

You likely have had a midi connection on a specific modulation number (ex. modulation 10 amount). So the next time you notice it, make aure all midi connections in the mod matrix have been cleared.

I’ll try and check this tomorrow, but I initialised the preset several times andeven closed and reopened Vital in both my Daw and as a stand-alone app.

I did have a midi keyboard connected but I did not specifically establch a midi connection other than the default.

@SlavaCat I think you may have been correct in saying that

It seems that my old midi keyboard may have been transmitting spurious midi CC events, but I still think that as I did not assign any midi control codes to any controls (the patch was ver simple: Osc 1 off, Osc 2 on, Env 2 assigned to OSC 2 Level) then Vital should have ignored these spurious command codes.

I am now trying to replicate the issue, without much success so far, to identify the CC.

a midi command that was once assigned will stay “forever” and is not part of a preset. closing or initializing things will not help there. you can right click on the control on question and remove the midi binding

Thanks @lokki for clarifying that. I do not remember assigning any midi commands, but even so, I feel that after uninstalling and reinstalling the app, then any settings should be removed. And rogue messages should be ignored.

It would be helpful if the Routing/Modulation Matrix showed midi control assignments, or if midi assignments are displayed somewhere else (I think that the Routing/Modulation Matrix would be the obvious place).

If they are already available somewhere could you let me know, please?

You can see your active MIDI learns in the config file in:


You can manually delete the connections or just look to figure out which one it is and delete it in Vital.

+1 for making this visible in-app, will open a request!

Thanks, I’ve had a look at the config file and I have extracted a part of it which is below.


Are these the parameters that II should delete?

For the record, Vital has long had an issue with mysterious Midi learn connections showing up even when the end user did not intentionally make such connections.

It’s been a known issue for quite some time so I’d be surprised if it would still be present in 1.5.5 so I imagine the connection was made in an earlier version of Vital and just never overwritten by updates.

These parameters shouldn’t have anything to do with modulation, I don’t think deleting them will solve the inversion problem.

I think I may have found th esource of the original issue. My keyboard is several years old (it is a m-audio Oxygen 49). I have found references to older keyboards generating random midi commands from worn faders and pots on the internet.

The suggested solution is to try to clean the pots, but…

Having said this, I feel I should reiterate that having some sort of matrix display of the midi cc assignments would be advantageous to users. I know that @SlavaCat has raised a request for something as a new feature.

1 Like