Messed up GUI with Vital VST3 in Reaper (Linux)


I’m using Vital 1.07 (also tried 1.08) with Ubuntustudio 20.04.4 (with XFCE) in the latest Reaper. When opening the GUI for the first time it looks like this:

Opening it the second time it usually looks fine. Wonder if this is meanwhile solved in the latest beta version? If so I would upgrade to the Pro version. :slight_smile:

I haven’t seen that before, manjaro linux kde plasma here.
but in the downloads section, go to ‘all downloads’ and get 1.08 and see if that changes anything.

As written it happens also with 1.08. I have Laptop where it is fine, but on the PC it looks like above. Both are non 4 K displays.

sorry, i didn’t see the 1.08 when i replied. I too use reaper and linux and haven’t heard of nor seen this problem yet, but in any case it doesn’t look good.

are you using the native linux version? have you tried the windows version with yabridge?

Thanks. I just tried the latest Ubuntustudio 22.04 with KDE and there it’s working fine too. I “fixed” it more or less by running Vital as a dedicated process in Reaper. It seems better and the GUI looks good when opening it the frist time, but the GUI also behaves glitchy sometimes when moving the window.

I never used yabridge. VST2 and LV2 is also not working for me. Completely crashes reaper.

edit: ok… also not working… got some audio drop outs and now the GUI looks like this:


It’s working also in Bitwig and Renoise, only Reaper has the issue.

dedicated mode doesn’t work well for me, i just leave it at “default” (and reaper disabled the setting that lets you choose the default but that’s another story) for awhile i was using “native” and that worked much better than “separate” or “dedicated”

hm, this is a weird one. it could be an openGL issue but i’m not sure.

It’s fixed in the latest version :smiley:

1 Like