Loading single cycle waves in Vital's Sampler


Yesterday I found a problem with Vital’s sampler. Shortly, I wanted to make a bass patch and I used all 3 oscillators. Still, I wanted to layer a sub without sacrificing any of these OSCs. Also i didn’t want to do that in post, I like to get as close as possible to finished sounds in the actual patch. So I decided to load a sub sample in the sampler, which I was not using for this particular sound.

I resampled a sine wave in Ableton, pitched at C1. Or C0. Maybe. Apparentlty there’s no standard nomenclature for note names. Let’s just say it was playing at 32,70 Hz (and if A4 = 440 Hz that makes it a C1). Note was recorded for a few seconds at 48000 kHz sample rate and at 32 bit.

Then I moved to Audacity, where you can select a portion of a file based on sample count. I did my math and found that a single cycle of a sine wave oscillating at 32,70 Hz and recorded at 48000 kHz amounts to 1468 samples (rounded). I skipped the first few cycles and selected a single cycle based on the specified window, double checked that the beggining and end of selection were at zero-crossing and exported.

In the end I got this single cycle sine wave to use as my sub and imported it into Vital’s sampler by drag and drop. And it sounds broken. When played at original pitch it sound buzzy and clicky. If played at double speed (65,40 Hz, C2) oddly enough it sounds fine and loops seamless. The seamless looping is preserved up to the note B in the same octave, then if you move up to C3 (130,80 Hz) is broken again. All buzzy and clicky.

I thougth I made some mistake in the sampling process, but then I imported the sub into Ableton’s stock sampler, and it worked. Loops seamless and sounds good no matter what note I play. Then I imported the same sample in Serum’s sampler. Loops seamless. For good measure I also imported the same sample in Phaseplant’s sampler. And it just loops seamless as well.

I suppose Vital’s sampler was not designed to work this way, but well, every other sampler I tried just handles the single cycle as expected

Sampler’s broken, pls fix

EDIT: I should also mention I’m on the freeware version, latest build