LMMS refusing to accept Vital.dll

Hi, so I’m using LMMS on Windows as my DAW. I finally managed to find the .dll file for Vital to feed into the VeSTige player on LMMS, but when I go into VeSTige and click on the file, nothing happens. It just refuses to open it into LMMS? It opens in Reaper just fine, so there’s nothing wrong with my Vital download, and LMMS can open other VSTs fine. What’s the issue?

I got VeSTige to load it fine, have you tried just dragging in Vital from the file browser?

Still doesn’t work

Are you on the most current version of LMMS?

Yes, LMMS 1.2.2

Describe your process with as much detail as possible, included images would also be helpful. I’m able to load Vital v.1.0.8 into LMMS v1.2.2 through VeSTige so there’s either something wrong with your process or your Vital install, have you tried reinstalling Vital?

Add VeSTige track
Open VeSTige
Open the file searcher in VeSTige and navigate to the folder where I keep my .dll files, including Vital
Click on Vital, which promptly returns me to back to the empty VeSTige.
For a comparison, when I do the same process but with a different .dll file, it loads.
Image below shows these, in order. I apologise for not being able to show the screenshots separately, the forums only let me post one single image.

I’m really not sure what’s up then, you could try signing out of Vital and working offline through the standalone version, removing the need to connect to internet, which could be causing it to crash before it loads up.

I can try signing out of my Vital account and loading the .dll file?

Yes, I can’t guarantee that will fix it, but its a common solution to startup crashes. I didn’t suggest it before because it seems to be a loading issue, just be warned, you won’t have access to TTWT while logged out.