LFO-modulated FX value doesn't reset after releasing note (1.0.7)

OS: Windows 10
DAW: Reaper, but I tested it standalone
Vital: 1.0.7

So I just update to 1.0.7, and the FX is going nuts haha. I don’t know how to describe it really, like for example a delay/reverb (all of them, not just these two) with feedback and mix all at 0, but being modulated by a LFO. When I release the note, the value is suppose to reset to 0 and cut the effects out completely, but it doesn’t haha. I also tested a patch that I made before I update, with same result.

I have a video here to show you what I meant (TURN DOWN YOUR VOLUME please, delay at 100% feedback is no joke lol):

Thanks for reading!

Update 1: I have tried downgrade to 1.0.6 and 1.0.5, but the problem still persist. The weirdest thing is that 1.0.5 work fine for me before I upgrade.

Can you send me the preset? It’s supposed to hold at the lfo position when the voice dies but it looks like it’s jumping.

1 Like

Wait, is it suppose to hold there, because I have never seen anything like that haha.
The jumping might be because my ENV1 has a little bit of release.
I’ve attached the patch, but I forgot to mention that this happen to factory patch to, my bad.ame squeal lol.vital (479.2 KB)

Edit 1: I think I might be big dumb here if the value are suppose to hold there haha, but I always thought that the value will go to the default right after I release the note which I set to 0. This morning I realized that an ENV would be much better for my purpose. I’m just a beginner so this “might” not be a bug at all haha.

I have the same issue with the FX filter - random position after note release.
In my understanding this behaviour is not intended, as the same LFO on the main filter does go back to its default value.

In case of a rather simple modulation replacing the LFO with an Env does the job.
However, in case of more complex movements Envs are no option.

Is there a fix to be expected? Seems like this bug exists for more than 8 months :disappointed_relieved: