Keyboard Mod and Pitch Wheels not working in Bitwig 3.3

There is some sort of bug with Bitwig 3.3, when using the mod wheel on an external keyboard. The mod wheel is being ignored from my keyboard. The mod wheel indicator in the Vital GUI does move with MIDI input from the keyboard, so it is receiving the input.

If I change the mod wheel using the Vital GUI, the modulation works. Strangely, mod wheel automation from Bitwig via the time line or a Bitwig modulator is also working just fine. It only seems to be ignored when the MIDI comes direct from my keyboard, even though Vital recognizes the input by moving the GUI mod wheel.

My other synths don’t have this issue.

This is on Mac, VST2, in Bitwig 3.3. The Keyboard is a KK S61. I’m using the Jürgen Moßgraber KK scripts.

I tested this in Ableton 11b19, and in Logic 10.6, and the mod wheel works just fine there. This only seems to be an issue with Bitwig.

Ptich wheel has the same behavior.

I did find a workaround though: Since mod and pitch work via automation, you can capture the mod and pitch wheels in Bitwig, and assign them to the mod and pitch wheel automation parameters in Vital.

The weird thing is that Vital obviously sees the messages, because the graphic of the wheels changes - it just doesn’t pass the values along.

Just confirming that this is still the same in 1.0.4

This is happening to me on Ableton Live 11 with a Yamaha PSR E413 as a MIDI controller. Works fine with other VST’s.

This is most likely because vital is set to MPE mode in Live11 by default. There was a post in another thread that described a fix by explicitly setting non MPE mode for vital, a search should bring it up. Probably right click on the plugin view frame in ableton…

1 Like

You’re right!! Thanks