Issue with changing wavetables

When using user wavetables, I can’t use the right arrow to switch to other wavetables, only the left arrow works. The arrows both work as expected when using the factory wavetables.
I’m using the VST3 version (1.0.5) in Reaper (6.19) on Windows 10.

Still not fixed. Recorded a short video, showing the issue.

Hmm, I added a bunch of folders with wavetables and this works fine for me. I select a folder and can browse left and right to go through the list.

1.0.7 vst3 on Linux

also works here, both directions, all folders, also the “User” folder
osx audiounit, logicX, v1.0.6

search only works withIN the selected folder
i’d rather like to have it gloablly…
maybe a new feature request thread…if i haven’t already…

Might be a Windows-specific bug then.

I tested the stand-alone version, same thing. So it’s not a Reaper issue.

weird, works for me.

only thing i could think of, maybe a problem with the path of your user file.

if you click on “all”, at the top?

Ok, so it seems this only happens when the user wavetables are within folders. If I put them in user/wavetables directly, I can switch back and forth with the arrows. But having them in folders is much better, because I like to keep things organized.

i have complete mess with wavetables and presets, 5 GB, but search funktion is very good. :upside_down_face:

maybe it helps if you click on the folder within the user folder first?
when i click user folder then the arrows, it still choses from global. but if i click one of the wavetables in user folder first it works as expected.

So the problem seems to lie with custom folders. When I click on the “user folder” item, I can switch wavetables as expected, even when they aren’t in the root wavetable directory. But as soon as I add a custom folder (user/wavetables/glork tables 1 for example) the advance arrow doesn’t work, only the back arrow.

does change with keyboard arrow work in both direction when wt browser is open?

Yes, works in both directions with arrow keys. Should have tried before, thx.

yes! that’s it! thank you! :slight_smile:

1 Like