Having trouble importing/exporting voice .wav file to pitch

Hi everyone!

I’m trying to create an emulation of an analogue oscillator with continuous wave shape control.

Problem: the resulting .wav file i export from the Vital wave editor is always 5 keys up from the original sample i recorded in my DAW.

My workflow is this:

  • I record a short C0 or C1 note of every ‘base’ wave shape i need (no filtering, envelope or effects obvs.)
  • I isolate a single wave cycle from each wave shape, making sure each cycle is the exact same sample count (2698 samples at 88.200 Khz) and stitch them together one after the other.
  • I export the result from my DAW at 88.200 Khz / 16 bit and import it into Vital’s wave editor.
  • I set the exact start and end point of every key frame (in my case 6 in total).
  • I set the blend style of the key frames to Time.

Now when i play my keyboard in Vital, there’s no difference at all in note pitch between my preset and the innit preset. But when i export to .wav from the wave editor and import the file back into Cubase (same project sample rate and bit depth as the .wav file) theres a 5+ key difference in pitch.

As far as i can tell, the oscillator pitch settings in Vital have no influence on the file exported from the wave editor.

What i’m going to try next is import a file that is recorded at -5 keys from the base pitch i really need from the resulting wavetable. But i’m pretty sure that’s not going to work.

Can someone tell me what’s going on here?
Why does Vital change the base pitch of a short series of single cycle wave forms, and what is that change based on?

I’ve seen video tutorials advising to use vocoder for better pitch detection when importing samples , but i’m trying to keep the original sample as high quality and unaltered as possible.

Many thanks in advance!

Greets,
Peter