Have to turn MPE on/off after every project load to get Pitch Bend to work

Anybody know a workaround for this bug? Hasn’t been too much of a problem but it’s still kinda annoying to have to sort thru a bunch of vital’s and turn on/off mpe on every instance to get the pitchbends to register.


Ableton 11 / Windows 10

1 Like

If your not on the current version of Vital, you might want to consider updating to see if the issue is fixed. I recall MPE having some issues in older versions.

I am on the current version

Yep, this issue is still present for me too on Vital 1.5.5 (VST3 in Bitwig 4.4.6, Mac M1). Note that you can automate the MPE switch as a workaround, so you don’t have to manually fix every instance in your project.

1 Like

this has been the case for me since launch, years of no pitch bend working. it works on standalone not inside a vst host (i use vst2) tried both ablton 11 and 10 of late. still no change regardless of version.

pitch bend is received by the plug, as the wheel is moved, but the audio doesn’t not change. MPE toggles the correct behaviour , BUT then MPE status is not saved with a session. it is saved visually but not internall. for every session loaded every vital must be opened, MPE toggled off then on again , for any pitch bend to work.

1 Like

Are you saving the patch after enabling mpe? It’s part of the patch and not a general setting.

As far as I can tell, when the vst is loaded it loads the patch which sets mpe. It doesn’t care if you set the mpe in the session.

It’s saved in the session, it’s on when I load the project but doesn’t respond to any pitch bend messages until I turn it on/off again.

I have an issue where loading a prior session make the patch sound wrong like the settings are all wrong. Opening the sessions vital instance and reloading the patch (selecting the same patch) corrects the patch sound. Something isn’t right with the patch settings as loaded via the session.

Try again, but reload the patch and see if it is correct then. If so, then the code for loading patches in a session need some work.

In my case I’m on Linux (AVL-MXE 21.3) using Ardour 7.1 and Vital 1.5.5

I see other complaints about this, but I wanted to note that this is still a bug in the latest version of Vital.

With Vital 1.5.5, running in Live 11, the MPE Enabled button does not survive saving and reopening the Live Set. It’s shown as On, but has no effect until toggled Off, then On again.

That, and having MPE Enabled be a patch property instead of global, makes Vital really hard to use with MPE controllers. It’s a great synth, so I really hope this major obstacle to use is fixed soon.