Glitch / skip when bouncing Vital in Logic

Hi there,

My Vital synth part often skips during playback within the first two bars; and every time I bounce (within Logic), the Vital track skips or glitches and has a skip in it.

I’m running one instance of Vital, along with a few other tracks which have all been ‘frozen’ to reduce CPU load.

[I cannot currently attach examples as a new user of this forum but please let me know when I can.]

Pre-freezing the Vital track before bouncing still freezes it in with a skip. Additionally, the skip moves place along the length of song each time it is bounced or frozen.

I have also unfrozen and refrozen to make sure it’s not reading the frozen track, all to no avail. CPU load looks good from the CPU meter.

There are no other phantom or hidden notes playing within or alongside the track.

The pad within Vital is a very simple, analogue sounding pad, so not hugely demanding CPU-wise.

I have tried not performing other tasks on my laptop to free up CPU. To no avail. Still the glitch.

Can you advise? My laptop is 10 years old but the CPU load looks good on the CPU meter during playback, and no other high-load tracks suffer in this way, especially when frozen or bouncing.

MacBook Pro (Retina, 15-inch, Early 2013)
Processor: 2.7 GHz Quad-Core Intel Core i7
Memory: 16 GB 1600 MHz DDR3
MacOS Catalina 10.15.7 (19H2026)
Logic Pro 10.6.3
Vital (Free) 1.5.5

Is it the first two bars of the entire track or first two bars of playback? It’s common practice to not start songs at measure zero to avoid problems like this–if this is indeed the problem.

Thanks for getting back to me so quickly.

It’s the first two bars of the entire song/track.

Is the non-zero thing a known bug within Vital - or are you suggesting if often happens generally? No other plugin/instrument I’ve used has a zero/non-zero starting issue, so certainly in my case I doubt it’s that.

As far as I can remember, skipping hasn’t been brought up here before. I’m also suggesting that it does happen generally; however, this is usually with much older plugins so it’s strange why Vital would be doing this. Personally, I’ve noticed some inconsistencies when trying to bounce short complex ear candies from Vital, but I’ve never noticed a problem when exporting more heavily used and less complex instruments.

Something I’d also question, is this reproducible and consistent? Does this happen in every track with ever instance of Vital?

Thanks SlavaCat. That gives me an idea to recreate the track (carefully copying the MIDI), to make sure there’s no shenanigans hiding somewhere. Thanks.

1 Like

Problem solved.

Vital’s output was clipping. That simple! I didn’t realise Vital even had an output/volume. Now I do.

Thanks for helping me problem solve, SlavaCat. Much appreciated.

1 Like