FM mod source error?

I’m not sure if this is a bug or if it’s intentional, so I wanted to check here first.

If you use two sinusoids, and make osc 2 modulate osc 1, osc 2’s sound is played. This seems undesirable, because you can’t control the shape of the frequency modulation as you could in dexed as a good FM reference point. The modulation source will always be audible, since it’s level is linked to both it’s sound output and its modulation intensity.


I don’t hear the behavior you’re describing. I can set osc2 level to 0 and still FM-modulate osc1 with it. Bringing up the level of osc2 just mixes in the sine without altering the sound of osc1.

1 Like

Sorry, this was an error on my part. It seems I was using the sources in reverse.

If I enabled osc 1 and 2, and I wanted to use 2 as the mod source, I would set it to FM osc 1. Reading it out loud it seems like a command to osc 2. Telling it, “Frequency modulate osc 1.” In reality, it seems to work more along the lines of “Be frequency modulated by osc 1”

I appreciate the reply!

Ah I see why that could be confusing. I might rename that…

Interesting; the alternative interpretation never occurred to me because all the other options in that menu clearly alter the current oscillator’s waveform. Names like “FM by Osc2” might remove any ambiguity.

1 Like