Fl studio Wrapper Bug

Everytime i try to either:
-click on the Vst Wrapper settings
-click on the minimize button
-click on the Vital channel button

It just crashes fl studio. No screen turning white. Just 1 second of freeze and everything gets closed
I can’t use Processing tab, because it crashes the program, so fixed size buffers won’t work

Hmm, maybe it has something to do with Windows scaling? (I assume you use Windows as your OS since you didn’t specify it)

I just tested your steps in my FL and it works fine.

What version of Vital do you have? And which FL exe you run? (Scaled or normal?)

I advise using the VST 2 version in FL Studio for the time being.

sorry for a late reply. Newest version of fl studio Idk how to do windows scalling (yes i use windows)

Do you use VST2 or VST3 version of Vital? I think it can be what @teksonik suggested above tbh, but can’t be sure.

You could also try to update your GPU drivers, but that’s a wild guess.

And with that “scaled” thing: FL Studio has 2 different executable files (4 to be more exact but in this case we focus only on 64bit), one is main, another one is called “scaled”.
Main uses internal FL’s functions for handling windows and scaling, scaled one lets Windows OS handle that instead. In theory when plugin has some issues with it’s UI it is worth a shot to try to run FL “scaled” to see if the same issue persists. You can find both executables in

C:\Program Files\Image-Line\FL Studio 20

fl_exe

Yes I recommend using the VST 2 version of Vital in FL Studio at least for now. It seems to work much better than the VST 3 version.

I’ve seen that tip work for several people so far. I think you’re correct about the scaling. That seems to have been the issue for other people in the past.

Other than that all I can say is Vital works just fine in FL Studio here on two different systems and has since the early access version.

1 Like

im using the both none of them work

But did you try to move VST3 from C:\Program Files\Common Files\VST3 to a different location, for a sec, and then load FL Studio and Vital in it? It’ll make VST2 version load instead.

If this also doesn’t work for you & the methods described above aren’t working either, my last guess is just to check your OS scaling in Settings app, under System >> Display >> Scale and layout
it should be set to 100%, if it’s above, try to set it to 100% and apply the changes (as suggested in my first reply).

If it’s still not working then that’s the last guess from me. Wish I could help more but I can’t even reproduce your issue on my end.

The fact that Vital works fine in FL Studio for most people points to it being a system issue or user error.

Either the system doesn’t meet minimum specifications or the user is simply doing something wrong.

My issue is different I think:
Vital loads very slow (= when I open the Vital inside FL Studio 20 it takes a very long time to load/open). It can be already used in the project, but if I close the GUI of Vital and need to open it again (for tweak something etc) it takes long to load the GUI again.
I use VST2 version on Vital (I think I didn’t even installed VST3 since I tend to use only VST2 version hen it’s available).

I did find this option, but I didn’t understand how I can select. Maybe I should try again and see if I can figure it out/if this helps.

What are your computer specs. CPU, RAM, Video Card etc ?