FL Studio GUI Issue

So, I’m having a similar problem with Vital that I had with Helm when I was using FL Studio. I’m unable to use my system’s GUI scaling (which is 125%) with Vital without it completely looking warped and freezing my daw, leaving me unable to change a thing. If I set my daw’s GUI scaling to 100%, all’s well and dandy, but I find that way too small for me to work with, it’s just harder to see. Any solutions or anybody else having this issue at all?

4 Likes

I have this issue too. Its also the same with Helm, but I uninstalled that before I figured out about the GUI scaling in FLstudio. Like you, I found that Vital looks normal with FL Studio’s system GUI scaling set to 100% but now some things on the DAW interface are a bit too small for me.

You can upscale in your display settings in windows.

Im using FL 20, and initially, Vital was slightly too large, and I had to bump my taskbar over to the right so I could grab the bottom right corner, to drag it to a smaller size. I ended up with a black rectangle in the bottom right corner.
I then had to find “zoom” in options and decreased it to 70% so I could see it all.
I have a large 48" screen.
It seems to be fine now

same problem, this seems to be the only workaround for now, using the fixed resizable value

Works without a hitch now

My problem is more that, if my my main gui scaling isn’t 100%, I can’t even click anything on my daw or get it working in the slightest. It just freezes my daw and I’m forced to end the program via task manager.

I’m getting the same issue. I’m on FL Studio 12 in Windows 10. Im on a laptop with a 15.6 inch screen. I’ve upped my screeen resolution to 1920 x 1080 and I’ve changed all the GUI settings to 100%. I don’t have the option for 70% like people above have mentioned. The Vital synth is still larger than the screen meaning that even with the taskbar moved I am unable to get to the bottom corner to try and resize the window.

click on the V shaped logo in the top left hand corner and you’ll see the different zoom settings like 70%

3 Likes

Aha! thanks @Carbinax! that’s perfect!

1 Like

This is what it looks like for me at 125% GUI Scaling in FL Studios’ options.

4 Likes

Yep, same.

Try manually changing FL Studio’s ‘Main GUI Scaling’ to ‘100%’

1 Like

Just to add to the discussion here, I’ve found that trying to resize the standalone version of Vital by dragging its borders works fine, but inside FL Studio it seems impossible on my machine (using FL Studio version 20.7.3 on Windows 10).

The method shown by Carbinax (using the scaling options by clicking the “V” logo in Vital’s GUI) works fine here, at least.

1 Like

There are a few separate scaling issues but I think I’ve fixed most of them in the latest version - 1.0.4
If you update at https://account.vital.audio can you let me know if that works?

Hello, I updated but the problem persists… the GUI is a mess when working in FL Studio with 125% scalling (which I normally use)… only when scaling the FL Studio in 100% solves the problem, but its too small for the FL GUI

Does it work if the window is resized? You should be able to click and drag the bottom right.

There’s no way to resize when FL Studio is 125% scaled, because the interface is too messy… I always have to switch to 100% on FL and then I can resize Vital

I had the same issue @lcmartinsloyola, where the plugin still loads incorrectly. However, I was able to click the resize buttons in Vital itself, and as soon as Vital changes its size (it doesn’t matter what size you choose), it will display correctly. You can then select the size you want from there.

While this isn’t ideal (having to guess where the buttons are in the incorrect GUI), it’s certainly better than what it was. Maybe if Vital did some sort of size-refresh or something when it starts up, the issue might be resolved for good. I’m in no way a programmer though, I just hope that this discovery helps @Tytel debug the issue. I’m definitely glad that 1.0.4 works better though!

1 Like