Export in Ableton takes significantly more time when 'Include Return and Master Effects' is selected


Using Ableton 11, Vital 1.0.8, Windows 10.

I noticed a song export took 4-5h when vital is used in the project and ‘Include Return and Master Effects’ is selected.
The behavior is reproduced by:

  • having 1 track in the project with a vital vst synth, no other plugins, same behavior VST2 or VST3
  • using initial preset
  • enabling one or more effects in the effects tab in vital (CPU meter is going up from 4% without to 15% with all effects enabled)
  • enabling ‘include return and master effects’ when exporting the individual track in Ableton
  • there are no plugins on the master or return channels

Regardless whether the track exported holds a vital synth, the export takes about 10 minutes per track. If the ‘offending’ vital track is removed, the export takes about a minute.

The export speed is drastically quicker without the ‘include return and master effects’ option enabled, also around a minute per track.

It puzzles me how these effects in a per-track vital entity can affect the master?

If you need more information, let me know what I can do to elaborate :o)

Keep up the great work!

Hi @tom.sleebus

What are your full system specs and what audio driver are you using? What are your Ableton audio & export settings? Sharing screenshots of those may help someone else here spot a system related problem.

It does sound weird though! Did you allow the 4-5hr export to complete? I wouldn’t have!

I’m on a seriously old i7 2.8GHz laptop with upgraded 16GB RAM and 1TB SSD, running Windows 10 and Ableton 11.1 external Presonus soundcard with latest ASIO driver. No problems exporting here (with the same scenarios that you’ve mentioned above or any other high track count project I add Vital to), even with highest possible sample rates and bit depth every test I run behaves as expected; both PCM and MP3 export, using Normalize and dithering etc.

Hey @Slingshot, thanx for the speed of replying.

Full system specs are i7-6820HQ 2.7Ghz 4 core (I guess about 6y old), 32Gb RAM, 512Gb SSD, Ableton 11.1, Focusrite 2i2.

Export settings attached (audio settings will follow when I am allowed to do so, 'new user can only put image per post)

Regardless of the sound driver selected the issue is reproduceable, have it with the onboard Realtek WDM driver (I know) as with Focusrite ASIO as with ASIO4ALL. If my understanding of the process is correct, rendering is not affected by the type of sound output used. So the Audio settings I believe should not affect rendering, let me know if I miss the ball here completely…

When I perform in exactly the same source project:

  • Freeze/Flatten all tracks (so no Vital VST’s or any others, except on the Master/Return busses, which I left empty for this exercise)
  • Export with Master and Return effects
    It takes 10 min for the first step and 1 minute approx per track, so all together half an hour compared to half a day.

I can even recreate the issue with my template, so no single midi clip in it, no single audio clip in it, just some tracks with some presets. If I delete one of the vital tracks without in-synth effects enabled, no improvement. If I remove the vital track with in-synth effects enabled, bam, about 800% speed gain in exporting.

So, yes I do have a workaround now, FF and then Export, I’ll use that before sending to the mastering engineer :slight_smile:

Audio Settings…

Ah so we’re using quite similar machines… mine’s about 9 years old.

I’m just wondering why you’d need to export with a sample rate of 88.2kHz 32 bit AIFF. In most cases 44.1kHz 24 bit is totally cool or some engineers might ask for 48kHz 24 bit… usually always WAV though. Not saying it’s wrong, just wondering!

How many tracks have you got running on that 235 bar project and at what tempo? Or track count and total project length, in time.

How much space have you got left on your SSD?

My mastering engineer asked so I obeyed :D, let me get back to him for the drivers behind that request…

About 31 tracks, 140bpm, song length 6:53

SSD has about 150Gb left free

If you change your export settings to 44.1kHz 16 bit WAV, is the issue still happening?

Just tried it, it is similar. The export is slightly faster than when compared to the 88.2kHz/32bit setting (feeling-based, didn’t time it), but the difference between exporting 44.1kHz/16-bit with vital-vst3 tracks and the same export settings without those vital-vst3 tracks is (best educated guesstimate here) about 10x as fast.

So, with your initial export settings of 88.2kHz 32bit and a project length of 6.53 mins, you’re trying to render about 279 MB per track… 31 tracks is gonna produce roughly 8.6 GB of data. That’s a hell of a lot of data to be trying to render to audio and write to disk. While it’s not exceeding your available space, my guess is it’s gonna make your machine fall over and that’ll give you very high estimated export times. Switching on ‘Include Return and Master Effects’ will add to this.

That’s probably why freezing your tracks is helping as Live will temporarily render those to RAM (I think, I’m not 100% sure about this).

I’m probably not aswering the question as to why having Vital on a track might make this worse etc but there does seem to be a few system limitations with trying to export such huge amounts of data.

Not really sure what to suggest other than reducing your export settings or rather than trying to export each individual track, export stems or groups of tracks instead. Usually a mastering engineer will want stems unless they’re mixing the project for you as well as mastering. If they’re insisting on all tracks and you’re having trouble providing them, then pack the project up by going to File>Manage Files and then in the righ-hand window that opens up, make sure all your project files are contained within the project and down the bottom select ‘Create Pack’ and send them that as it’s effectively a Zip file of the whole project.

Thanx Slingshot
Indeed the other items you mention I’m familiar with. There must be something between Vital and the master as omitting either (FF will result in no Vital anymore, and exporting without master/return effects simulates ‘no master’) makes the issue go away. Maybe it is the upsampling setting combined with a internal Ableton use of 44.1kHz/32bit and that with export settings of even something else, but that’s me guessing around now…
I’ll stick to the ‘FF (that uses the audio settings, not the export settings) and only then export the project with effects’ workaround for now, that brings it back to half an hour, which I think is very descent for my pc here.
Would like to thank you for the time spent on reading/thinking along/writing, appreciate this!
Greetings from tiny Belgium

No worries man. I’m always happy to try and help. Sorry I couldn’t totally answer your question and perhaps it is a bug.

I’m glad you’re finding a workaround for the time being!

Good luck with your project :slight_smile:

I don’t use Ableton, but I think you should just bounce the track from the timeline. It may help.

Hi Silas,

Not sure what you mean with ‘bounce from the timeline’.

Bouncing the entire track is not an issue, takes some minutes. Just the selection ‘individual tracks’, and the option ‘include master and return effects’, like for sending to the mastering engineer, takes a long time.

I’m saying, try converting the track that is an issue into an audio file the way you do when you resample something.

That is the issue. As long as there is one vital track with effects in the song, exporting any track (not necessarily one with the vital vst) takes considerabley longer. Removing the ‘offending’ vital track solves the issue.
My current workaround is to freeze/flatten the vital track once i’m happy with it, hereby removing the vst. Exporting after this goes fast.

Your four-core CPU could be the root of the strangeness in the problem. Some DAWs do different tasks in each core. Ableton might be one of those DAWs.

Hi @siborg

I don’t think it’s anything to do with multicore CPU’s or the way Ableton handles multicore processing (which it does… very well).

Tom’s CPU is a 6th gen i7-6820HQ 2.7Ghz 4-Core, 8-Thread from Q3 2015

My CPU is a 4th gen i7-4710MQ 2.5Ghz 4-Core, 8-Thread from Q2 2014

Very similar CPU’s and I have absolutely no issues like Tom is describing.

Meant to reply to another thing. Rookie mistake.

Hi, I noticed you ve been using a Focusrite interface. Your audio settings in Live does not reflect this. You are using the MME Windows audio layer. But you may use the ASIO driver provided with your Focusrite. ASIO drivers are better for pro audio app and the one provided with your card is even optimized for this specific device.
Hope this helps.

Hi Christophe,

Thanx for your answer. I did understand that the ‘playback’ device has no impact on how ableton renders the tracks when bouncing. Of course you’re right, the wdm or mme devices take considerably more cpu, leaving less for the bounce process. I did try to reproduce with asio focusrite, asio4all and classic wdm driver (depends where i am while producing), the speed with asio is slightly better, but the difference with vital or without is still significant, regardless of the audio device selected.

1 Like