Envelope control of oscillators

Hope this is my lack of understanding, can you explain.

Initialize preset. Turn osc1 level to zero. Modulate osc1 level with env2 (slow attack). The output follows env1.

Initialize preset Turn osc1 level to zero. Modulate osc1 level with lfo1 (slow attack). The output follows lfo1.

1 Like

env 1 is master, open it if needed.

1 Like

Thanks but I’m still confused, let me put it another way. With osc1 level at zero there is no output. If osc1 level is now modulated with env2, why does output follow env1 and not env2 ?.

1 Like

It follows env2 (just turn down the sustain and release of env2) and you hear it.

1 Like

Now it seems to follow env2 attack and sustain then follows the release of env1.

1 Like

correct , now turn the release of env2 down to 0 an the sustain to 0 and the sound will have died before the release stage of env1 is reached.

Yes, I agree that’s how it works, but all I wanted was for osc1 to follow env2 as drawn with no effect from env1. Thanks for your help.

But you ALWAYS need env1 it is hardwired to the master volume, when you turn this down ADSR all to 0 you will never get a sound out of Vital.

If that was so, how would you have different adsr envelopes for each oscillator ?

Sorry but it works that way.
Set env1 attack to 32 seconds and try to make a “pluck” sound with any or all OSSs, using env2-whatever, it won’t work.
Try it !

Or use “Any preset” and set the attack of env1 to 32seconds.

Finally the penny drops. I was thinking env1 acted on all the osc level controls, not so, it is after the level controls in the flow. By setting env1 to a high level for as long as possible (30 odd seconds) and using env2 to modulate osc1 level, env2 controls the level that is sent to env1 and hence the output ( as env1 is set high). Thanks again for your help.

1 Like

Maybe I could have explained it better, but I’m glad you get it now :smiley:

I just turn the env1 release to more than 2 seconds and turn the release curve up to maximum.

env1%20release

But remember, please DON’T put the release more than 10 seconds it heavily eats CPU. It’s up to you. :slight_smile:

Astrotype :-
Thanks for the tip. For me, just reducing the release time stops audio breakup for some heavy patches.

1 Like