Drag to resize GUI doesn't work with VST3 version

I can confirm this is happening for me in both Ableton Live 10.1.30 Suite and Bitwig 3.2.8. The VST3 version of the plugin does not resize properly when the corner is dragged, but the VST2 version works as expected. Here’s a screenshot of what happens:

I’m using Vital 1.0.3 and Windows 10 Home version 20H2. I have an Nvidia 2080 Super, and I am using two displays.

Same problem over here. If I attempt scale it up, the window keeps forcing back to the original size, and if I scale it down, a large portion of the window will become black. Just as an extra data point, I’m using FL 20 and not Ableton, so it’s probably not DAW dependent.

Guys all you need - in the windows parameters where the display settings are, remove automatic scaling and make it what it should be!

Can you try clicking and dragging more inside the window on the bottom right (and not directly on the window corner). There’s another mechanism for resizing that works from the point inside the window.

Hi all!

First some specs:

I have a laptop that uses Optimus Prime technology (an Asus ROG GL552VW with NVIDIA-Intel GPUs)
I run linux (Ubuntu 21.04)
My DAW is Ardour (the version that comes from the Ubuntu repositories)

I have just encounter another problem with Vital VST3 plugin resizing…

  1. If I run Ardour with the predefined Prime profile, then Vital (vst3) just freezes if I try to resize it by dragging. By default it almost covers my screen). Also none of the predefined sizes e.g 50% 70% 100% e.t.c work.

  2. But if I run Ardour using the Dedicated Graphics Card (in my case NVIDIA) then I can resize Vital by dragging, though there are some glitches. However, trying to resize using the predefined sizes e.g from 50% to 100% or any other size and vice-versa, takes many seconds…

I hope I gave enough information to help Mat find what is going on…
For more clarification I’ll be at your disposal