Downloading Vital for the first time - unrecognised file?

Hi Helpers!

I just got onto Vital tonight to try out the free version before potentially buying it and have met a dissapointing first hurdle of not getting a download working at all.

Running a Mac Monteray 12.1 - this surely shouldnt be an outdated machine.

The download will work but then in the downloads tab in the Finder, it says ‘Unconfirmed 651453.crdownload’ and directs me to the app store. I have tried an unarchiver that i have installed but want to ask for advise first before seaching futher cause this shouldnt be happening!

Please note that i have checked to see if it was a security check but it is set to allow it.


Frustrated Dave :cold_sweat:

May I ask if your using the main website to download or a proxy link? Also if you are using safari, could you try another browser (chrome, Firefox) just to check as well?

Im downloading from the main website and im using Chrome. I will try Safari, see if i have any luck.

It worked! Download worked when using Safari. Not sure why, glad it was resolved. Thanks for your help!

Sweet, no clue either but glad it worked haha!